couchbase 0.0.2

couchbase.dart #

Couchbase client for Google's Dart language via Native Extensions and Couchbase C Client. This is targetted at Dart VM servers that expose domain specific Rest/Swagger/gRPC/GraphQL endpoints for Web/Mobile/Desktop clients STILL IN DEVELOPMENT

Building Prerequisites #

  1. install cmake required by libcoucbhase
  2. install libevent required by libcouchbase

Help Needed #

Drop Benjamin a mail if you'd like to contribute. He certainly needs a hand :)

References #

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  couchbase: ^0.0.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:couchbase/couchbase.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
6
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
3
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <2.0.0

Admin