copyable 0.0.1+2
copyable: ^0.0.1+2 copied to clipboard

Flutter Android iOS Linux macOS web Windows

A Flutter package for giving and standardizing copy functionality to Dart classes.

4
likes
90 / 110
pub points
76 %
popularity

We analyzed this package on Mar 2, 2021, and awarded it 90 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/README.md

10/10 points: 20% or more of the public API has dartdoc comments

  • 39 out of 80 API elements (48.8 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

INFO: 'title' is deprecated and shouldn't be used. Use "label" instead, as it allows for an improved text-scaling experience. This feature was deprecated after v1.19.0..

lib/src/builtins/builtins.dart:204:38

    ╷
204 │             icon: Icon(Icons.title), title: const Text('Title')),
    │                                      ^^^^^
    ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/builtins/builtins.dart

INFO: 'title' is deprecated and shouldn't be used. Use "label" instead, as it allows for an improved text-scaling experience. This feature was deprecated after v1.19.0..

lib/src/builtins/builtins.dart:206:38

    ╷
206 │             icon: Icon(Icons.image), title: const Text('Image')),
    │                                      ^^^^^
    ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/builtins/builtins.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer^0.36.30.36.41.1.0
build^1.1.41.6.21.6.3
code_builder^3.2.03.6.03.6.0
flutterflutter0.0.00.0.0
meta^1.1.61.3.0-nullsafety.31.3.0
source_gen^0.9.40.9.4+40.9.10+3
Transitive dependencies
PackageConstraintCompatibleLatest
args-1.6.02.0.0
async-2.4.22.5.0
built_collection-4.3.25.0.0
built_value-7.1.08.0.0
characters-1.1.0-nullsafety.31.1.0
charcode-1.1.31.2.0
collection-1.15.0-nullsafety.31.15.0
convert-2.1.13.0.0
crypto-2.1.53.0.0
csslib-0.16.20.17.0
dart_style-1.2.91.3.14
file-5.2.16.1.0
fixnum-0.10.111.0.0
front_end-0.1.190.1.29
glob-1.2.02.0.0
html-0.14.0+40.15.0
intl-0.16.10.17.0
js-0.6.20.6.3
kernel-0.3.190.3.29
logging-0.11.41.0.0
matcher-0.12.90.12.10
node_interop-1.2.11.2.1
node_io-1.2.01.2.0
package_config-1.9.32.0.0
path-1.7.01.8.0
pedantic-1.9.21.10.0
pub_semver-1.4.42.0.0
quiver-2.1.53.0.0
sky_engine-0.0.990.0.99
source_span-1.7.01.8.1
stack_trace-1.9.61.10.0
string_scanner-1.0.51.1.0
term_glyph-1.1.01.2.0
typed_data-1.3.0-nullsafety.31.3.0
vector_math-2.1.0-nullsafety.32.1.0
watcher-0.9.7+151.0.0
yaml-2.2.13.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.36.3` on analyzer does not support the stable version `0.37.0`.

Try running dart pub upgrade --major-versions analyzer to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.1+1, Flutter 1.22.6, Dart 2.10.5.

4
likes
90
pub points
76%
popularity

A Flutter package for giving and standardizing copy functionality to Dart classes.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

jfajardo200@gmail.com

License

MIT (LICENSE)

Dependencies

analyzer, build, code_builder, flutter, meta, source_gen

More

Packages that depend on copyable