cool_datepicker 1.0.5 copy "cool_datepicker: ^1.0.5" to clipboard
cool_datepicker: ^1.0.5 copied to clipboard

Cool datepicker ✨ This datepicker gives you cool animation, modern design, and you can customize colors and language for datepicker.

12
likes
130/ 160
pub points
67%
popularity

We analyzed this package 3 days ago, and awarded it 130 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

partial
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

31 out of 392 API elements (7.9 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

To highlight public API members missing documentation consider enabling the public_member_api_docs lint.

Some symbols that are missing documentation: SelectType, SelectType.SelectType, SelectType.SelectType.SelectType, animation_util, animation_util.AnimationUtil.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 3 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Web

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:cool_datepicker/cool_datepicker.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `Linux`.

Because:

  • package:cool_datepicker/cool_datepicker.dart that declares support for platforms: Android, iOS, Web.
Package does not support platform `macOS`.

Because:

  • package:cool_datepicker/cool_datepicker.dart that declares support for platforms: Android, iOS, Web.
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 37 issues. Showing the first 2:

WARNING: This class (or a class that this class inherits from) is marked as '@immutable', but one or more of its instance fields aren't final: CoolDatepicker.disabledList, CoolDatepicker.disabledRangeList, CoolDatepicker.minYear, CoolDatepicker.maxYear, CoolDatepicker.years, CoolDatepicker.onSelected, CoolDatepicker._selectedItems, CoolDatepicker._selectedRangeItem, CoolDatepicker.isRange, CoolDatepicker.format, CoolDatepicker.limitCount, CoolDatepicker.defaultValue, CoolDatepicker.weekLabelList, CoolDatepicker.monthLabelList, CoolDatepicker.weekLabelMapList, CoolDatepicker.monthLabelMapList, CoolDatepicker.isYearMonthDropdownReverse, CoolDatepicker.firstWeekDay, CoolDatepicker.headerColor, CoolDatepicker.arrowIconAreaColor, CoolDatepicker.selectedCircleColor, CoolDatepicker.selectedBetweenAreaColor, CoolDatepicker.cancelFontColor, CoolDatepicker.okButtonColor, CoolDatepicker.bottomSelectedBorderColor, CoolDatepicker.cancelBtnLabel, CoolDatepicker.okBtnLabel, CoolDatepicker.placeholder, CoolDatepicker.isResultLabel, CoolDatepicker.isResultIconLabelReverse, CoolDatepicker.isDark, CoolDatepicker.resultWidth, CoolDatepicker.resultHeight, CoolDatepicker.iconSize, CoolDatepicker.calendarSize, CoolDatepicker.resultAlign, CoolDatepicker.resultPadding, CoolDatepicker.resultBD, CoolDatepicker.resultTS, CoolDatepicker.placeholderTS, CoolDatepicker.labelIconGap

lib/cool_datepicker.dart:7:7

  ╷
7 │ class CoolDatepicker extends StatefulWidget {
  │       ^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/cool_datepicker.dart

WARNING: The '!' will have no effect because the receiver can't be null.

lib/cool_datepicker.dart:290:50

    ╷
290 │     Overlay.of(datePickerIconKey.currentContext!)!.insert(_overlayEntry);
    │                                                  ^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/cool_datepicker.dart

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
flutter_web_plugins flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.6, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

12
likes
130
pub points
67%
popularity

Publisher

unverified uploader

Cool datepicker ✨ This datepicker gives you cool animation, modern design, and you can customize colors and language for datepicker.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, flutter_web_plugins

More

Packages that depend on cool_datepicker