contextx 0.1.1

  • Readme
  • Changelog
  • Installing
  • 44

contextx #

contextx is a quality of life package that provides extensions on BuildContext for Flutter. It lets you replace calls like Navigator.of(context) with context.navigator().

Requirements #

Dart version 2.7.0 or higher.

Changelog #

Refer to the Changelog to get all release notes.

[0.1.1] - 2020/05/19 #

  • Fix dependency on flutter >1.17.

[0.1.0] - 2020/05/19 #

  • Initial version.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  contextx: ^0.1.1

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:contextx/cupertino.dart';
import 'package:contextx/material.dart';
import 'package:contextx/widgets.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Jul 3, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.13
  • Flutter: 1.17.5

Analysis suggestions

Package not compatible with SDK dart

because of import path [contextx] that is in a package requiring null.

Health suggestions

Format lib/material.dart.

Run flutter format to format lib/material.dart.

Format lib/widgets.dart.

Run flutter format to format lib/widgets.dart.

Maintenance issues and suggestions

Homepage URL doesn't exist. (-20 points)

At the time of the analysis the homepage field was unreachable.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and contextx.dart. Packages with multiple examples should provide example/

For more information see the pub package layout conventions.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.7.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8
Dev dependencies