console_cmd 1.0.5

Dart native
Flutter Android iOS

A library include i/o tools to build cmd application efficiently

3
likes
80 / 110
pub points
66 %
popularity

We analyzed this package on Oct 27, 2020, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 22 out of 31 API elements (71.0 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:console_cmd/console_cmd.dart that imports:
  • package:console_cmd/src/stdin.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 5 issues. Showing the first 2:

lib/src/constants.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/src/cursor.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

No dependencies.

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

3
likes
80
pub points
66%
popularity

A library include i/o tools to build cmd application efficiently

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

a1950207@gmail.com

License

BSD (LICENSE)

More

Packages that depend on console_cmd