conreality_beacon 0.0.1

  • Readme
  • Changelog
  • Installing
  • 48

conreality_beacon #

Project license Pub package Dartdoc reference

Radio beacon gadget support for Conreality live-action games.

Compatibility #

Android (5.0+). (iOS support is planned.)

Examples #

Importing the package #

import 'package:conreality_beacon/conreality_beacon.dart';

Installation #

pubspec.yaml using Pub

dependencies:
  # See: https://pub.dev/packages/conreality_beacon
  conreality_beacon: ^0.0.1

pubspec.yaml using Git

dependencies:
  # See: https://github.com/conreality/conreality-plugins/tree/master/conreality_beacon
  conreality_beacon:
    git:
      url: https://github.com/conreality/conreality-plugins.git
      path: conreality_beacon

See Also #

Follow @ConrealityCode and @ConrealityGame on Twitter for project updates.

Changelog #

All notable changes to this project will be documented in this file.

The format is based on Keep a Changelog, and this project adheres to Semantic Versioning.

0.0.1 - 2019-07-13 #

Added #

  • ConrealityBeacon.version getter

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  conreality_beacon: ^0.0.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:conreality_beacon/conreality_beacon.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
48
Learn more about scoring.

We analyzed this package on Nov 21, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.6.0
  • pana: 0.12.21
  • Flutter: 1.9.1+hotfix.6

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Maintenance suggestions

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.4.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
meta 1.1.7 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test