connectivity_linux 0.0.0-dev.1
connectivity_linux: ^0.0.0-dev.1 copied to clipboard

Linux implementation for `connectivity` plugin

0
likes
60/ 130
pub points
40%
popularity

We analyzed this package on Nov 30, 2021, and awarded it 60 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 21 out of 26 API elements (80.8 %) have documentation comments.
Support multiple platforms
0 / 20

0/20 points: Supports 0 of 3 possible platforms (iOS, Android, Web)

Found 7 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Android`.

Because:

  • package:connectivity_linux/connectivity_linux.dart that declares support for platforms: Linux.
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/connectivity_linux.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
connectivity_platform_interface^1.0.61.0.62.0.1
dbus^0.0.0-dev.160.0.0-dev.230.6.6
flutterflutter0.0.00.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
args-1.6.02.3.0
characters-1.1.01.2.0
charcode-1.3.11.3.1
collection-1.15.01.15.0
convert-2.1.13.0.1
meta-1.7.01.7.0
petitparser-3.1.04.4.0
plugin_platform_interface-1.0.32.0.2
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1
xml-4.5.15.3.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.0.6` on connectivity_platform_interface does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions connectivity_platform_interface to update the constraint.

The constraint `^0.0.0-dev.16` on dbus does not support the stable version `0.1.0`.

Try running dart pub upgrade --major-versions dbus to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.4, Flutter 2.5.3, Dart 2.14.4.