configuration_cards 0.0.2+1 copy "configuration_cards: ^0.0.2+1" to clipboard
configuration_cards: ^0.0.2+1 copied to clipboard

A Flutter package to quickly create widgets to display basic application settings or similar.

1
likes
130/ 140
pub points
0%
popularity

We analyzed this package 6 days ago, and awarded it 130 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

4 out of 13 API elements (30.8 %) have documentation comments.

Some symbols that are missing documentation: configuration_cards, configuration_cards.ConfigSetting, configuration_cards.ConfigSetting.ConfigSetting, configuration_cards.ConfigSetting.currentPageButtonTitle, configuration_cards.ConfigSetting.onTapButton.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

INFO: 'subtitle1' is deprecated and shouldn't be used. Use titleMedium instead. This feature was deprecated after v3.1.0-0.0.pre.

lib/configuration_cards.dart:124:46

    ╷
124 │                   style: themeData.textTheme.subtitle1!
    │                                              ^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/configuration_cards.dart

INFO: 'bodyText2' is deprecated and shouldn't be used. Use bodyMedium instead. This feature was deprecated after v3.1.0-0.0.pre.

lib/configuration_cards.dart:165:32

    ╷
165 │           style: textThemeData.bodyText2!.copyWith(
    │                                ^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/configuration_cards.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
smooth_page_indicator ^1.0.0+2 1.1.0 1.1.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.

1
likes
130
pub points
0%
popularity

Publisher

verified publisherflutterplus.ir

A Flutter package to quickly create widgets to display basic application settings or similar.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, smooth_page_indicator

More

Packages that depend on configuration_cards