compasstools 0.1.0 copy "compasstools: ^0.1.0" to clipboard
compasstools: ^0.1.0 copied to clipboard

Useful tools to access sensors to develop a Compass App for Android devices

6
likes
30/ 140
pub points
45%
popularity

We analyzed this package 2 days ago, and awarded it 30 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

Failed to verify repository URL.

Please provide a valid repository URL in pubspec.yaml, such that:

  • repository can be cloned,
  • a clone of the repository contains a pubspec.yaml, which:,
    • contains name: compasstools,
    • contains a version property, and,
    • does not contain a publish_to property.

pubspec.yaml from the repository has no repository or homepage URL.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-2-Clause.

failed
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

Dependency resolution failed, unable to run dartdoc.

10/10 points: Package has an example

failed
Platform support
0 / 20trigger folding of the section

0/20 points: Platform support detection failed

Could not determine supported platforms as package resolution failed.

Run flutter pub get for more information.

failed
Pass static analysis
0 / 50trigger folding of the section

0/50 points: code has no errors, warnings, lints, or formatting issues

  • Running flutter pub outdated failed with the following output:
The lower bound of "sdk: '>=2.1.0 <3.0.0'" must be 2.12.0'
or higher to enable null safety.
failed
Support up-to-date dependencies
0 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Sdk constraint doesn't support current Dart version 3.4.0-131.0.dev. Cannot run `flutter pub outdated`.

pubspec.yaml:8:8

  ╷
8 │   sdk: ">=2.1.0 <3.0.0"
  │        ^^^^^^^^^^^^^^^^
  ╵

0/10 points: Package supports latest stable Dart and Flutter SDKs

Sdk constraint doesn't support current Dart version 3.4.0-131.0.dev.

pubspec.yaml:8:8

  ╷
8 │   sdk: ">=2.1.0 <3.0.0"
  │        ^^^^^^^^^^^^^^^^
  ╵

Try widening the upper boundary of the constraint.

The current SDK constraint does not allow the Dart version used by the latest stable Flutter (3.3.0)

pubspec.yaml:8:8

  ╷
8 │   sdk: ">=2.1.0 <3.0.0"
  │        ^^^^^^^^^^^^^^^^
  ╵

Analyzed with Pana 0.22.0, Flutter 3.19.0, Dart 3.3.0.

Check the analysis log for details.

6
likes
30
pub points
45%
popularity

Publisher

unverified uploader

Useful tools to access sensors to develop a Compass App for Android devices

Repository (GitHub)
View/report issues

License

BSD-2-Clause (LICENSE)

Dependencies

flutter

More

Packages that depend on compasstools