community_charts_flutter 1.0.0 icon indicating copy to clipboard operation
community_charts_flutter: ^1.0.0 copied to clipboard

Material Design charting library for flutter. Forked from google/charts.

13
likes
120/ 140
pub points
86%
popularity

We analyzed this package 31 hours ago, and awarded it 120 pub points (of a possible 140):

icon indicating section status
Follow Dart file conventions
30 / 30icon to trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

icon indicating section status
Provide documentation
20 / 20icon to trigger folding of the section

10/10 points: Package has an example

10/10 points: 20% or more of the public API has dartdoc comments

  • 149 out of 354 API elements (42.1 %) have documentation comments.
icon indicating section status
Platform support
20 / 20icon to trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, MacOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ MacOS
  • ✓ Web
icon indicating section status
Pass static analysis
20 / 30icon to trigger folding of the section

20/30 points: code has no errors, warnings, lints, or formatting issues

INFO: 'bodyText2' is deprecated and shouldn't be used. Use bodyMedium instead. This feature was deprecated after v3.1.0-0.0.pre.

lib/src/behaviors/legend/legend_entry_layout.dart:134:45

    ╷
134 │       color ??= Theme.of(context).textTheme.bodyText2!.color;
    │                                             ^^^^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/behaviors/legend/legend_entry_layout.dart

icon indicating section status
Support up-to-date dependencies
10 / 20icon to trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
collection^1.14.51.17.01.17.1
community_charts_common^1.0.01.0.01.0.0
flutterflutter0.0.00.0.0
intl^0.17.00.17.00.18.0
logging^1.0.21.1.11.1.1
meta^1.1.11.8.01.8.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.2.11.2.1
clock-1.1.11.1.1
js-0.6.50.6.7
material_color_utilities-0.2.00.2.0
path-1.8.31.8.3
sky_engine-0.0.990.0.99
vector_math-2.1.42.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.17.0` on intl does not support the stable version `0.18.0`.

Try running dart pub upgrade --major-versions intl to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

icon indicating section status
Support sound null safety
20 / 20icon to trigger folding of the section

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.25, Flutter 3.7.0, Dart 2.19.0.

13
likes
120
pub points
86%
popularity

Publisher

verified publisher iconsteenbakker.dev

Material Design charting library for flutter. Forked from google/charts.

Repository (GitHub)

Documentation

API reference

License

Icon for licenses.Apache-2.0 (LICENSE)

Dependencies

collection, community_charts_common, flutter, intl, logging, meta

More

Packages that depend on community_charts_flutter