codecov 1.0.0
codecov: ^1.0.0 copied to clipboard

Generates lcov and/or HTML coverage reports for Dart projects. (UNIX only)

2
likes
35 / 130
pub points
59 %
popularity

We analyzed this package on Jul 28, 2021, and awarded it 35 pub points (of a possible 130):

Follow Dart file conventions
5 / 20

0/10 points: Provide a valid pubspec.yaml

Sdk-constraint doesn't allow future stable dart 2.x releases

pubspec.yaml:10:8

   ╷
10 │   sdk: ">=2.0.0 <2.11.0"
   │        ^^^^^^^^^^^^^^^^^
   ╵

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 2 links are insecure.

README.md:2:139

  ╷
2 │ <p><a href="https://travis-ci.org/codecov/dart"><img src="https://travis-ci.org/codecov/dart.svg?branch=master" alt="Build Status" /></a> <a href="http://codecov.io/github/codecov/dart?branch=master"><img src="http://codecov.io/github/codecov/dart/coverage.svg?branch=master" alt="codecov.io" /></a>
  │                                                                                                                                           ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

Use https URLs instead.

Links in `README.md` should be secure. 1 image link is insecure.

README.md:2:201

  ╷
2 │ <p><a href="https://travis-ci.org/codecov/dart"><img src="https://travis-ci.org/codecov/dart.svg?branch=master" alt="Build Status" /></a> <a href="http://codecov.io/github/codecov/dart?branch=master"><img src="http://codecov.io/github/codecov/dart/coverage.svg?branch=master" alt="codecov.io" /></a>
  │                                                                                                                                                                                                         ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

Use https URLs instead.

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/example.dart

0/10 points: Failed to run dartdoc

  • Failed to resolve dependencies.
stdout: MSG : Resolving dependencies...
stderr: FINE: Pub 2.13.4
SLVR: fact: codecov is 1.0.0
SLVR: derived: codecov
SLVR: fact: codecov requires SDK version >=2.0.0 <2.11.0
SLVR: conflict: codecov requires SDK version >=2.0.0 <2.11.0
SLVR: Version solving took 0:00:00.037582 seconds.
    | Tried 1 solutions.
FINE: Resolving dependencies finished (0.050s).
ERR : The current Dart SDK version is 2.13.4.
    | 
    | Because codecov requires SDK version >=2.0.0 <2.11.0, version solving failed.
FINE: Exception type: SolveFailure
FINE: package:pub/src/solver/version_solver.dart 308:5               VersionSolver._resolveConflict
    | package:pub/src/solver/version_solver.dart 129:27              VersionSolver._propagate
    | package:pub/src/solver/version_solver.dart 93:11               VersionSolver.solve.<fn>
    | ===== asynchronous gap ===========================
    | dart:async                                                     Future.catchError
    | package:pub/src/utils.dart 113:52                              captureErrors.wrappedCallback
    | package:stack_trace                                            Chain.capture
    | package:pub/src/utils.dart 126:11                              captureErrors
[...]
    | 
    | Because codecov requires SDK version >=2.0.0 <2.11.0, version solving failed.
FINE: Exception type: SolveFailure
FINE: package:pub/src/solver/version_solver.dart 308:5               VersionSolver._resolveConflict
    | package:pub/src/solver/version_solver.dart 129:27              VersionSolver._propagate
    | package:pub/src/solver/version_solver.dart 93:11               VersionSolver.solve.<fn>
    | ===== asynchronous gap ===========================
    | dart:async                                                     Future.catchError
    | package:pub/src/utils.dart 113:52                              captureErrors.wrappedCallback
    | package:stack_trace                                            Chain.capture
    | package:pub/src/utils.dart 126:11                              captureErrors
    | package:pub/src/command.dart 164:13                            PubCommand.run
    | package:args/command_runner.dart 196:27                        CommandRunner.runCommand
    | package:dartdev/dartdev.dart 199:30                            DartdevRunner.runCommand
    | package:args/command_runner.dart 112:25                        CommandRunner.run.<fn>
    | dart:async                                                     new Future.sync
    | package:args/command_runner.dart 112:14                        CommandRunner.run
    | package:dartdev/dartdev.dart 53:29                             runDartdev
    | /b/s/w/ir/cache/builder/sdk/pkg/dartdev/bin/dartdev.dart 11:9  main
---- End log transcript ----
Support multiple platforms
0 / 20

0/20 points: Supports 0 of 2 possible platforms (native, js)

Package resolution failed. Could not determine platforms.

Run dart pub get for more information.

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 5 issues. Showing the first 2:

bin/generate_coverage.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

bin/src/coverage.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
0 / 20

0/10 points: All of the package dependencies are supported in the latest version

Sdk constraint doesn't support current Dart version 2.13.4. Cannot run `dart pub outdated`.

pubspec.yaml:10:8

   ╷
10 │   sdk: ">=2.0.0 <2.11.0"
   │        ^^^^^^^^^^^^^^^^^
   ╵

0/10 points: Package supports latest stable Dart and Flutter SDKs

Sdk constraint doesn't support current Dart version 2.13.4.

pubspec.yaml:10:8

   ╷
10 │   sdk: ">=2.0.0 <2.11.0"
   │        ^^^^^^^^^^^^^^^^^
   ╵

Try widening the upper boundary of the constraint.

Support sound null safety
0 / 20

0/20 points: Unable to detect null safety

Package resolution failed. Could not determine null safety.

Run dart pub get for more information.

Analysed with Pana 0.19.0, Dart 2.13.4.

2
likes
35
pub points
59%
popularity

Publisher

codecov.io

Generates lcov and/or HTML coverage reports for Dart projects. (UNIX only)

Repository (GitHub)
View/report issues

License

Apache 2.0 (LICENSE)

Dependencies

args, logging, path

More

Packages that depend on codecov