code_builder 4.10.0 copy "code_builder: ^4.10.0" to clipboard
code_builder: ^4.10.0 copied to clipboard

A fluent, builder-based library for generating valid Dart code

215
likes
160/ 160
pub points
93%
popularity

We analyzed this package 42 hours ago, and awarded it 160 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

440 out of 744 API elements (59.1 %) have documentation comments.

Some symbols that are missing documentation: code_builder, code_builder.BinaryExpression.accept, code_builder.BinaryExpression.addSpace, code_builder.BinaryExpression.left, code_builder.BinaryExpression.operator.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
built_collection ^5.0.0 5.1.1 5.1.1
built_value ^8.0.0 8.9.2 8.9.2
collection ^1.15.0 1.19.0 1.19.0
matcher ^0.12.10 0.12.16+1 0.12.16+1
meta ^1.3.0 1.15.0 1.15.0
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
boolean_selector - 2.1.1 2.1.1
fixnum - 1.1.0 1.1.0
path - 1.9.0 1.9.0
source_span - 1.10.0 1.10.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
string_scanner - 1.3.0 1.3.0
term_glyph - 1.2.1 1.2.1
test_api - 0.7.3 0.7.3

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.9, Dart 3.4.4.

Check the analysis log for details.

215
likes
160
pub points
93%
popularity

Publisher

verified publishertools.dart.dev

A fluent, builder-based library for generating valid Dart code

Repository (GitHub)
View/report issues
Contributing

Documentation

API reference

License

BSD-3-Clause (license)

Dependencies

built_collection, built_value, collection, matcher, meta

More

Packages that depend on code_builder