codable 1.0.0
codable: ^1.0.0 copied to clipboard

Dart native js
Flutter Android iOS Linux macOS web Windows

A serialization library for converting dynamic, structured data (JSON, YAML) into Dart types.

2
likes
85 / 110
pub points
87 %
popularity

We analyzed this package on Mar 4, 2021, and awarded it 85 pub points (of a possible 110):

Follow Dart file conventions
15 / 20

10/10 points: Provide a valid pubspec.yaml

0/5 points: Provide a valid README.md

Links in `README.md` should be secure. 1 link is insecure.

README.md:110:30

    ╷
110 │ <p>See the specification for <a href="http://json-schema.org">JSON Schema</a> and the <code>$ref</code> keyword for more details.</p>
    │                              ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
    ╵

Use https URLs instead.

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 22 out of 79 API elements (27.8 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 33 issues. Showing the first 2:

INFO: Unnecessary new keyword.

lib/cast.dart:63:15

   ╷
63 │       : throw new FailedCast(context, key, "$from is not an int");
   │               ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/cast.dart

INFO: Unnecessary new keyword.

lib/cast.dart:71:15

   ╷
71 │       : throw new FailedCast(context, key, "$from is not an double");
   │               ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/cast.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
meta^1.1.51.3.01.3.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.2, Dart 2.12.0.

2
likes
85
pub points
87%
popularity

A serialization library for converting dynamic, structured data (JSON, YAML) into Dart types.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

joe.conway@stablekernel.com

License

BSD (LICENSE)

Dependencies

meta

More

Packages that depend on codable