cochl_sense 1.1.0 copy "cochl_sense: ^1.1.0" to clipboard
cochl_sense: ^1.1.0 copied to clipboard

API Library for Dart with audio analysis and recognition solutions from Cochlear.ai

3
likes
20/ 140
pub points
0%
popularity

We analyzed this package 23 hours ago, and awarded it 20 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://github.com/cochlearai/sense-dart was unreachable. Make sure that the website is reachable via HEAD requests.

Failed to verify repository URL.

Please provide a valid repository URL in pubspec.yaml, such that:

  • repository can be cloned,
  • a clone of the repository contains a pubspec.yaml, which:,
    • contains name: cochl_sense,
    • contains a version property, and,
    • does not contain a publish_to property.

Unable to access git repository: Failed to run remote show origin.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

failed
Provide documentation
0 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

Dependency resolution failed, unable to run dartdoc.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

failed
Platform support
0 / 20trigger folding of the section

0/20 points: Platform support detection failed

Could not determine supported platforms as package resolution failed.

Run dart pub get for more information.

failed
Pass static analysis
0 / 50trigger folding of the section

0/50 points: code has no errors, warnings, lints, or formatting issues

  • Running dart pub outdated failed with the following output:
The lower bound of "sdk: '>=2.3.0 <3.0.0'" must be 2.12.0'
or higher to enable null safety.
failed
Support up-to-date dependencies
0 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Sdk constraint doesn't support current Dart version 3.4.0. Cannot run `dart pub outdated`.

pubspec.yaml:7:8

  ╷
7 │   sdk: ">=2.3.0 <3.0.0"
  │        ^^^^^^^^^^^^^^^^
  ╵

0/10 points: Package supports latest stable Dart and Flutter SDKs

Sdk constraint doesn't support current Dart version 3.4.0.

pubspec.yaml:7:8

  ╷
7 │   sdk: ">=2.3.0 <3.0.0"
  │        ^^^^^^^^^^^^^^^^
  ╵

Try widening the upper boundary of the constraint.

Analyzed with Pana 0.22.3, Dart 3.4.0.

Check the analysis log for details.

3
likes
20
pub points
0%
popularity

Publisher

verified publishercochlear.ai

API Library for Dart with audio analysis and recognition solutions from Cochlear.ai

Repository (GitHub)
View/report issues

License

MIT (LICENSE)

Dependencies

fixnum, grpc, protobuf

More

Packages that depend on cochl_sense