cmd 0.0.8 copy "cmd: ^0.0.8" to clipboard
cmd: ^0.0.8 copied to clipboard

The cmd package is a command line tool for Flutter Developers that is used to run the most common shell/bash commands via pre-built scripts.

9
likes
130/ 140
pub points
56%
popularity

We analyzed this package 16 hours ago, and awarded it 130 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

2 out of 3 API elements (66.7 %) have documentation comments.

Some symbols that are missing documentation: dev_tools.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:cmd/cmd.dart that imports:
  • dart:io
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.8.0
meta - 1.11.0 1.12.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

0/10 points: Package supports latest stable Dart and Flutter SDKs

  • Found no Flutter in your PATH. Could not determine the current Flutter version.

Analyzed with Pana 0.22.1, Dart 3.3.0.

Check the analysis log for details.

9
likes
130
pub points
56%
popularity

Publisher

verified publisherusama.dev

The cmd package is a command line tool for Flutter Developers that is used to run the most common shell/bash commands via pre-built scripts.

Repository (GitHub)
View/report issues
Contributing

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter

More

Packages that depend on cmd