clibu 1.5.0 copy "clibu: ^1.5.0" to clipboard
clibu: ^1.5.0 copied to clipboard

A tiny library to make the writing of command-line apps intuitive.

3
likes
130/ 140
pub points
0%
popularity

We analyzed this package 45 hours ago, and awarded it 130 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

Homepage URL doesn't exist.

At the time of the analysis https://github.com/iamtheblackunicorn/cli was unreachable. Make sure that the website is reachable via HEAD requests.

Failed to verify repository URL.

Please provide a valid repository URL in pubspec.yaml, such that:

  • repository can be cloned,
  • a clone of the repository contains a pubspec.yaml, which:,
    • contains name: clibu,
    • contains a version property, and,
    • does not contain a publish_to property.

Unable to access git repository: Failed to run remote show origin.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

16 out of 23 API elements (69.6 %) have documentation comments.

Some symbols that are missing documentation: clibu, clibu.CommandLineApp.appAuthor, clibu.CommandLineApp.appLicense, clibu.CommandLineApp.appName, clibu.CommandLineApp.appVersion.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:clibu/clibu.dart that imports:
  • package:clibu/src/files.dart that imports:
  • dart:io
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
pedantic ^1.11.0 1.11.1 1.11.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.0, Dart 3.3.0.

Check the analysis log for details.

3
likes
130
pub points
0%
popularity

Publisher

verified publisherblckunicorn.art

A tiny library to make the writing of command-line apps intuitive.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

pedantic

More

Packages that depend on clibu