chroma 0.1.0-dev
chroma: ^0.1.0-dev copied to clipboard

A color library for creating, converting and manipulating colors.

2
likes
90 / 130
pub points
0 %
popularity

We analyzed this package on May 8, 2021, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 13 out of 22 API elements (59.1 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 14 issues. Showing the first 2:

INFO: This function has a return type of 'String', but doesn't end with a return statement.

lib/src/chroma_base.dart:81:14

   ╷
81 │   String get format {
   │              ^^^^^^
   ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/chroma_base.dart

INFO: This function has a return type of 'String', but doesn't end with a return statement.

lib/src/chroma_base.dart:277:10

    ╷
277 │   String toCssString({String format}) {
    │          ^^^^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run flutter analyze lib/src/chroma_base.dart

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
collection-1.15.01.15.0
meta-1.3.01.3.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.1.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.16.0, Flutter 2.0.5, Dart 2.12.3.

2
likes
90
pub points
0%
popularity

A color library for creating, converting and manipulating colors.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

knnawm@gmail.com

License

MIT (LICENSE)

Dependencies

flutter

More

Packages that depend on chroma