chico_flutter_sdk 0.1.0 copy "chico_flutter_sdk: ^0.1.0" to clipboard
chico_flutter_sdk: ^0.1.0 copied to clipboard

Chico conta a história dos seus clientes por meio das suas transações financeiras.

1
likes
100/ 160
pub points
24%
popularity

We analyzed this package 43 hours ago, and awarded it 100 pub points (of a possible 160):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

0/10 points: Use an OSI-approved license

No license was recognized.

Consider using an OSI-approved license in the LICENSE file to make it more accessible to the community.

failed
Provide documentation
0 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

OUT: Documenting chico_flutter_sdk... Discovering libraries... Linking elements... Precaching local docs for 609279 elements... Initialized dartdoc with 795 libraries Generating docs for library connector_webview.dart from package:chico_flutter_sdk/connector_webview.dart... Generating docs for library chico_flutter_sdk.dart from package:chico_flutter_sdk/chico_flutter_sdk.dart... Generating docs for library data_harvester.dart from package:chico_flutter_sdk/data_harvester.dart... Documented 3 public libraries in 65.9 seconds ERR: The warning 'missing-code-block-language' is deprecated. The warning 'missing-code-block-language' is deprecated. The warning 'missing-code-block-language' is deprecated. The warning 'missing-code-block-language' is deprecated. The warning 'missing-code-block-language' is deprecated. The warning 'missing-code-block-language' is deprecated. The warning 'missing-code-block-language' is deprecated. The warning 'missing-code-block-language' is deprecated. The warning 'missing-code-block-language' is deprecated. The warning 'missing-code-block-language' is deprecated. [4947 more lines]

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 2 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS

These platforms are not supported:

Package does not support platform `Windows`.

Because:

  • package:chico_flutter_sdk/chico_flutter_sdk.dart that imports:
  • package:chico_flutter_sdk/data_harvester.dart that imports:
  • package:chico_harvest_plugin/chico_harvest_plugin.dart that declares support for platforms: Android, iOS.
Package does not support platform `Linux`.

Because:

  • package:chico_flutter_sdk/chico_flutter_sdk.dart that imports:
  • package:chico_flutter_sdk/data_harvester.dart that imports:
  • package:chico_harvest_plugin/chico_harvest_plugin.dart that declares support for platforms: Android, iOS.
Package does not support platform `macOS`.

Because:

  • package:chico_flutter_sdk/chico_flutter_sdk.dart that imports:
  • package:chico_flutter_sdk/data_harvester.dart that imports:
  • package:chico_harvest_plugin/chico_harvest_plugin.dart that declares support for platforms: Android, iOS.
Package does not support platform `Web`.

Because:

  • package:chico_flutter_sdk/chico_flutter_sdk.dart that imports:
  • package:chico_flutter_sdk/data_harvester.dart that imports:
  • package:chico_harvest_plugin/chico_harvest_plugin.dart that declares support for platforms: Android, iOS.
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

WARNING: This API is available since SDK 2.15.0, but constraints '>=2.13.1 <3.0.0' don't guarantee it.

lib/connector_webview.dart:49:120

   ╷
49 │           'https://connector.chico.ai/?userId=${widget.token}&client=${widget.client}&environment=${widget.environment.name}'));
   │                                                                                                                        ^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/connector_webview.dart

WARNING: This API is available since SDK 2.15.0, but constraints '>=2.13.1 <3.0.0' don't guarantee it.

lib/data_harvester.dart:56:26

   ╷
56 │       widget.environment.name,
   │                          ^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/data_harvester.dart

failed
Support up-to-date dependencies
30 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
chico_harvest_plugin ^0.0.2 0.0.2 0.0.2
flutter flutter 0.0.0 0.0.0
mixpanel_flutter ^1.6.0 1.6.0 2.3.1
webview_flutter >=4.0.0 <=4.0.7 4.0.7 4.8.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
flutter_web_plugins - 0.0.0 0.0.0
js - 0.6.7 0.7.1
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
path - 1.9.0 1.9.0
plugin_platform_interface - 2.1.8 2.1.8
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4
webview_flutter_android - 3.16.4 3.16.4
webview_flutter_platform_interface - 2.10.0 2.10.0
webview_flutter_wkwebview - 3.14.0 3.14.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.6.0` on mixpanel_flutter does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions mixpanel_flutter to update the constraint.

The constraint `>=4.0.0 <=4.0.7` on webview_flutter does not support the stable version `4.1.0`.

Try running dart pub upgrade --major-versions webview_flutter to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.9, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

1
likes
100
pub points
24%
popularity

Publisher

verified publisherchico.ai

Chico conta a história dos seus clientes por meio das suas transações financeiras.

Homepage

Documentation

API reference

License

unknown (license)

Dependencies

chico_harvest_plugin, flutter, mixpanel_flutter, webview_flutter

More

Packages that depend on chico_flutter_sdk