chess_lib 0.1.0+2 copy "chess_lib: ^0.1.0+2" to clipboard
chess_lib: ^0.1.0+2 copied to clipboard

Dart library for chess. Use this package for modelling a game of chess.

3
likes
120/ 140
pub points
18%
popularity

We analyzed this package 3 days ago, and awarded it 120 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: Apache-2.0.

partial
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

5 out of 51 API elements (9.8 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Some symbols that are missing documentation: chess_lib, chess_lib.ChessGameState.availableCastling, chess_lib.ChessGameState.board, chess_lib.ChessGameState.check, chess_lib.ChessGameState.copyGameState.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
partial
Pass static analysis
40 / 50trigger folding of the section

40/50 points: code has no errors, warnings, lints, or formatting issues

Found 17 issues. Showing the first 2:

INFO: The file name 'chess-game-state.dart' isn't a lower_case_with_underscores identifier.

To reproduce make sure you are using the lints_core and run dart analyze lib/src/chess-game-state.dart

INFO: The file name 'chess-move.dart' isn't a lower_case_with_underscores identifier.

To reproduce make sure you are using the lints_core and run dart analyze lib/src/chess-move.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

No dependencies.

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Dart 3.4.0.

Check the analysis log for details.

3
likes
120
pub points
18%
popularity

Publisher

verified publisherthkp.co

Dart library for chess. Use this package for modelling a game of chess.

Repository (GitHub)
View/report issues

Documentation

API reference

License

Apache-2.0 (LICENSE)

More

Packages that depend on chess_lib