checkbox_list_tile_more_customizable 2.0.0

  • Readme
  • Changelog
  • Example
  • Installing
  • 82

checkbox_list_tile_more_customizable #

A CheckboxListTile with more customizable details.

Introduction #

This project is a modified version of Flutter CheckboxListTile, and provides more customizable functions, with these functions, you can set the horizontalTitleGap, minVerticalPadding, minLeadingWidth, contentPadding.

Usage #

CheckboxListTileMoreCustomizable(
  value: tmp,
  title: Text("CheckboxListTileMoreCustomizable!"),
  horizontalTitleGap: 16,
  contentPadding: EdgeInsets.symmetric(horizontal: 16),
  minLeadingWidth: 40,
  minVerticalPadding: 10,
  onChanged: (v) {
    setState(() {
      tmp = v;
    });
  },
);

Example #

Example

[2.0.0] - 2020-07-13 #

  • From this version, the dependency list_tile_more_customizable will not all exported, and with this version, only ListTileMoreCustomizableDefaultValue and ListTileMoreCustomizableControlAffinity has been exported.
  • Due to the new version may cause some problems when using list_tile_more_customizable directly from checkbox_list_tile_more_customizable in the past, the major version has jumped to 2.X.Y. If you want to upgrade checkbox_list_tile_more_customizable to 2.0.0+, sometimes you may need to import list_tile_more_customizable independently for this upgrade.

[1.0.2] - 2020-04-03 #

  • Export dependency list_tile_more_customizable so the value of ListTileMoreCustomizableControlAffinity.platform, ListTileMoreCustomizableControlAffinity.leading, ListTileMoreCustomizableControlAffinity.trailing, ListTileMoreCustomizableDefaultValue.horizontalTitleGap, ListTileMoreCustomizableDefaultValue.contentPadding, ListTileMoreCustomizableDefaultValue.minVerticalPadding, ListTileMoreCustomizableDefaultValue.minLeadingWidth can be used directly, and also ListTileMoreCustomizable is available without adding ListTileMoreCustomizable directly to the dependency.

[1.0.1] - 2020-03-22 #

  • Update dependency version which fixed a hot reload problem.

[1.0.0] - 2020-03-21 #

  • This project is a modified version of Flutter CheckboxListTile, and provides more customizable functions, with these functions, you can set the horizontalTitleGap, minVerticalPadding, minLeadingWidth, and contentPadding.

example/lib/main.dart

import 'package:flutter/material.dart';
import 'package:checkbox_list_tile_more_customizable/checkbox_list_tile_more_customizable.dart';

void main() => runApp(MyApp());

class MyApp extends StatelessWidget {
  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      title: 'Flutter Demo',
      home: MyHomePage(title: 'Flutter Demo Home Page'),
    );
  }
}

class MyHomePage extends StatefulWidget {
  MyHomePage({Key key, this.title}) : super(key: key);

  final String title;

  @override
  _MyHomePageState createState() => _MyHomePageState();
}

class _MyHomePageState extends State<MyHomePage> {
  bool tmp = true;

  @override
  Widget build(BuildContext context) {
    return Scaffold(
      appBar: AppBar(
        title: Text(widget.title),
      ),
      body: ListView(
        children: <Widget>[
          CheckboxListTileMoreCustomizable(
            value: tmp,
            title: Text("CheckboxListTileMoreCustomizable!"),
            horizontalTitleGap: 16,
            contentPadding: EdgeInsets.symmetric(horizontal: 16),
            minLeadingWidth: 40,
            minVerticalPadding: 10,
            onChanged: (v) {
              setState(() {
                tmp = v;
              });
            },
          )
        ],
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  checkbox_list_tile_more_customizable: ^2.0.0

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:checkbox_list_tile_more_customizable/checkbox_list_tile_more_customizable.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
64
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
82
Learn more about scoring.

We analyzed this package on Jul 13, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.15
  • Flutter: 1.17.5

Analysis suggestions

Package not compatible with SDK dart

Because:

  • checkbox_list_tile_more_customizable that is a package requiring null.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
list_tile_more_customizable ^1.3.0 1.3.0
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8 1.2.2
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8 2.1.0-nullsafety
Dev dependencies
flutter_test