chat_list 0.0.1+21

  • Readme
  • Changelog
  • Example
  • Installing
  • new68

chat_list #

A flutter package to incorporate a chat view in a simple way and jump start your chat application.

Pub GitHub stars

Example #

See source

Usage #

//Create a list with messages
  List<MessageModel> _messageList = [
    MessageModel("Hi, how are you?", OwnerType.SENDER, ownerName: "Higor Lapa"),
    MessageModel("Hi, I'm fine and you?!", OwnerType.RECEIVER,
        ownerName: "Bill Gates")

//Place the widget inside your build function
  messageList: _messageList,

[0.0.1+21] - 12/22/2019

  • Fixes the screenshot link in the readme file and reorder the changelog

[0.0.1+2] - 12/22/2019

  • Updates the file with examples

[0.0.1] - 12/20/2019

  • initial release


example #

A new Flutter project.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  chat_list: ^0.0.1+21

2. Install it

You can install packages from the command line:

with Flutter:

$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:chat_list/chat_list.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Jan 16, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.7.0
  • pana: 0.13.4
  • Flutter: 1.12.13+hotfix.5

Health suggestions

Format lib/models/message_model.dart.

Run flutter format to format lib/models/message_model.dart.

Format lib/models/owner_type_enum.dart.

Run flutter format to format lib/models/owner_type_enum.dart.

Format lib/widgets/message_widget.dart.

Run flutter format to format lib/widgets/message_widget.dart.

Maintenance issues and suggestions

Support latest dependencies. (-10 points)

The version constraint in pubspec.yaml does not support the latest published versions for 1 dependency (flare_flutter).

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
bubble ^1.1.9+1 1.1.9+1
flare_flutter ^1.8.3 1.8.3 2.0.1
flutter 0.0.0
Transitive dependencies
collection 1.14.11 1.14.12
flare_dart 2.3.3
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies