charset_converter 2.2.0 copy "charset_converter: ^2.2.0" to clipboard
charset_converter: ^2.2.0 copied to clipboard

Charset/encoding converter that uses underlying platform - no external dependencies

53
likes
140/ 140
pub points
95%
popularity

We analyzed this package 3 days ago, and awarded it 140 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

5 out of 11 API elements (45.5 %) have documentation comments.

Some symbols that are missing documentation: charset_converter, charset_converter.CharsetConversionError, charset_converter.CharsetConversionError.CharsetConversionError, charset_converter.CharsetConversionError.decoding, charset_converter.CharsetConversionError.encoding.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 4 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux

These platforms are not supported:

Package does not support platform `macOS`.

Because:

  • package:charset_converter/charset_converter.dart that declares support for platforms: Android, iOS, Windows, Linux.
Package does not support platform `Web`.

Because:

  • package:charset_converter/charset_converter.dart that declares support for platforms: Android, iOS, Windows, Linux.
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.18.0
material_color_utilities - 0.8.0 0.11.1
meta - 1.11.0 1.14.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.3, Flutter 3.19.5, Dart 3.3.3.

Check the analysis log for details.

53
likes
140
pub points
95%
popularity

Publisher

verified publisherpr0gramista.pl

Charset/encoding converter that uses underlying platform - no external dependencies

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

flutter

More

Packages that depend on charset_converter