chaquopy 0.0.8
chaquopy: ^0.0.8 copied to clipboard

Chaquopy plugin which uses chaquopy sdk to run the python script on flutter apps.

1
likes
90 / 110
pub points
31 %
popularity

We analyzed this package on Apr 8, 2021, and awarded it 90 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 2 out of 4 API elements (50.0 %) have documentation comments.
Support multiple platforms
0 / 20

0/20 points: Supports 1 of 3 possible platforms (iOS, Android, Web)

Found 7 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform iOS

Because:

  • package:chaquopy/chaquopy.dart that declares support for platforms: Android
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
flutterflutter0.0.00.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
collection-1.15.01.15.0
meta-1.3.01.3.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Flutter 2.0.4, Dart 2.12.2.

1
likes
90
pub points
31%
popularity

Chaquopy plugin which uses chaquopy sdk to run the python script on flutter apps.

Repository (GitHub)
View/report issues

Documentation

API reference

Uploader

jayjaydangar96@gmail.com

License

MIT (LICENSE)

Dependencies

flutter

More

Packages that depend on chaquopy