cassandart 0.3.0

Dart native
Flutter Android iOS

Cassandra database client (driver wire protocol: v4, CQL: 3.0).

Cassandra database client in Dart #

  • The package can be used with Cassandra (and Elassandra).
  • It is able to handle basic types (but: no map yet).
  • Detects and auto-connects peers.
  • Auto-selects peers with lower latencies.
  • Select the peer that is most likely to contain the data (use: hint).

This is an experimental library and protocol, use at your own risk.

How to contribute #

Check and follow the spec of the wire protocol v4 before creating a PR.

1
likes
80
pub points
25%
popularity

Publisher

agilord.com

Cassandra database client (driver wire protocol: v4, CQL: 3.0).

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD (LICENSE)

Dependencies

buffer, meta, page

More

Packages that depend on cassandart