card_scanner 0.0.4

  • Readme
  • Changelog
  • Example
  • Installing
  • new51

💳 card_scanner #

Fast , Accurate and Secure Credit & Debit card scanner

card_scanner is a flutter plugin for accurately and quickly scanning debit and credit cards.

Documentation & Samples 📖 #

Features #

  • 🔒Fully OFFLINE scan makes it a completely secure scanner !
  • 🎈 Can scan Expiry date , Card Holder name and Card Issuer (lacked by other scanners) along with the Card number
  • 🔋Powered by Google's Machine Learning models
  • ⚡ Great performance and accuracy
  • 🎚Supports controlling parameters that determine the balance between speed and accuracy
  • ❤️ Simple, powerful, & intuitive API

Install #

Add this to your package's pubspec.yaml file:

dependencies:
  card_scanner: <latest-version>

Usage #

Just import the package and call scanCard

import 'package:card_scanner/card_scanner.dart';
var cardDetails = await CardScanner.scanCard()

print(cardDetails)

Example Output :

Card Number = 5173949117389006 
Expiry Date = 11/26

The above code opens the device camera , looks for a valid card and gets the required details and returns the CardDetails object


Scan Options : #

If you wish to obtain the card holder name and card issuer , you can specify the options.

import 'package:card_scanner/card_scanner.dart';
var cardDetails = await CardScanner.scanCard(
    scanOptions: CardScanOption (
        scanCardHolderName: true, 
        scanCardIssuer: true
    )
);


print(cardDetails)

Example Output :

Card Number = 5173949117389006 
Expiry Date = 11/26
Card Issuer = mastercard
Card Holder Name = PAUL SAMUELSON

What next ? #

  • IOS support coming very soon 🚀
  • More control options for scanning behavior
  • Better optimizations for name scanning is in the todo list :)

0.0.1 #

  • First Release

example/lib/main.dart

import 'package:flutter/material.dart';
import 'dart:async';

import 'package:flutter/services.dart';
import 'package:card_scanner/card_scanner.dart';

void main() {
  runApp(MyApp());
}

class MyApp extends StatefulWidget {
  @override
  _MyAppState createState() => _MyAppState();
}

class _MyAppState extends State<MyApp> {
  CardDetails _cardDetails;

  @override
  void initState() {
    super.initState();
  }

  // Platform messages are asynchronous, so we initialize in an async method.
  Future<void> scanCard() async {
    CardDetails cardDetails;
    try {
      cardDetails =
          await CardScanner.scanCard(scanOptions: CardScanOptions(scanCardHolderName: true, scanCardIssuer: true));
    } on PlatformException catch (e) {
      print('Failed to get platform version : $e');
      return;
    }

    // If the widget was removed from the tree while the asynchronous platform
    // message was in flight, we want to discard the reply rather than calling
    // setState to update our non-existent appearance.
    if (!mounted) return;

    setState(() {
      _cardDetails = cardDetails;
    });
  }

  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      home: Scaffold(
        appBar: AppBar(
          title: const Text('Plugin example app'),
        ),
        body: Center(
          child: Column(
            mainAxisAlignment: MainAxisAlignment.spaceEvenly,
            children: [
              RaisedButton(
                onPressed: () async {
                  scanCard();
                },
                child: Text('scan card'),
              ),
              Text('$_cardDetails')
            ],
          ),
        ),
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  card_scanner: ^0.0.4

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:card_scanner/card_scanner.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
10
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
83
Overall:
Weighted score of the above. [more]
51
Learn more about scoring.

We analyzed this package on Jul 3, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.13
  • Flutter: 1.17.5

Analysis suggestions

Package does not support Flutter platform linux

Because of import path [package:card_scanner/card_scanner.dart] that declares support for platforms: android, ios

Package does not support Flutter platform macos

Because of import path [package:card_scanner/card_scanner.dart] that declares support for platforms: android, ios

Package does not support Flutter platform web

Because of import path [package:card_scanner/card_scanner.dart] that declares support for platforms: android, ios

Package does not support Flutter platform windows

Because of import path [package:card_scanner/card_scanner.dart] that declares support for platforms: android, ios

Package not compatible with SDK dart

because of import path [card_scanner] that is in a package requiring null.

Health issues and suggestions

Document public APIs. (-1 points)

19 out of 19 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Format lib/models/card_details.dart.

Run flutter format to format lib/models/card_details.dart.

Maintenance suggestions

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

The package description is too short. (-7 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.7.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8
Dev dependencies
flutter_test