canny_edge_detection 1.0.2
canny_edge_detection: ^1.0.2 copied to clipboard

An edge detection library.

2
likes
80 / 110
pub points
44 %
popularity

We analyzed this package on Apr 8, 2021, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 4 out of 7 API elements (57.1 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 4 issues. Showing the first 2:

INFO: DO use curly braces for all flow control structures.

lib/src/canny.dart:288:48

    ╷
288 │     for (var i = 0; i < currentThreshold; ++i) background_mean += i * histogramm[i];
    │                                                ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/canny.dart

INFO: DO use curly braces for all flow control structures.

lib/src/canny.dart:292:50

    ╷
292 │     for (var i = currentThreshold; i < 256; ++i) foreground_mean += i * histogramm[i];
    │                                                  ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
    ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/canny.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
image^2.0.02.1.193.0.2
Transitive dependencies
PackageConstraintCompatibleLatest
archive-2.0.133.1.2
args-1.6.02.0.0
charcode-1.2.01.2.0
collection-1.15.01.15.0
convert-2.1.13.0.0
crypto-2.1.53.0.1
meta-1.3.01.3.0
path-1.8.01.8.0
petitparser-3.1.04.1.0
typed_data-1.3.01.3.0
xml-4.5.15.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^2.0.0` on image does not support the stable version `3.0.1`.

Try running dart pub upgrade --major-versions image to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Dart 2.12.2.