candlesticks 2.1.0 copy "candlesticks: ^2.1.0" to clipboard
candlesticks: ^2.1.0 copied to clipboard

A high-performance full featured candlesticks chart for all platforms.

134
likes
140/ 160
pub points
88%
popularity

We analyzed this package 28 hours ago, and awarded it 140 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

14 out of 34 API elements (41.2 %) have documentation comments.

Some symbols that are missing documentation: candlesticks, candlesticks.Candle.Candle.fromJson, candlesticks.Candle.isBull, candlesticks.MultiThemeColorExtension, candlesticks.MultiThemeColorExtension.background.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:candlesticks/candlesticks.dart that imports:
  • package:candlesticks/src/main.dart that imports:
  • dart:io
failed
Pass static analysis
30 / 50trigger folding of the section

30/50 points: code has no errors, warnings, lints, or formatting issues

Found 15 issues. Showing the first 2:

WARNING: Duplicate import.

lib/src/main.dart:10:8

   ╷
10 │ import 'models/candle.dart';
   │        ^^^^^^^^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/main.dart

WARNING: Duplicate import.

lib/src/widgets/candle_stick_widget.dart:3:8

  ╷
3 │ import '../models/candle.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/widgets/candle_stick_widget.dart

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.6, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

134
likes
140
pub points
88%
popularity

Publisher

verified publisherrmzy.dev

A high-performance full featured candlesticks chart for all platforms.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

flutter

More

Packages that depend on candlesticks