calendar_calendar 1.0.0
calendar_calendar: ^1.0.0 copied to clipboard

A Calendar Custom Widget, you can selected dates, limited dates, and beautiful interface

9
likes
90/ 130
pub points
83%
popularity

We analyzed this package on Oct 22, 2021, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 2 out of 27 API elements (7.4 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Consider supporting multiple platforms:

Package not compatible with runtime flutter-web on Web

Because:

  • package:calendar_calendar/calendar_calendar.dart that imports:
  • package:calendar_calendar/src/calendar_page.dart that imports:
  • package:calendar_calendar/src/widgets/calendar_widget.dart that imports:
  • package:calendar_calendar/src/widgets/controller.dart that imports:
  • package:calendar_calendar/src/service.dart that imports:
  • package:calendar_calendar/src/utils/date_utils.dart that imports:
  • dart:io
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/src/calendar_page.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/src/widgets/calendar_widget.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
animate_do^2.0.02.0.02.0.0
animated_text_kit^4.1.14.2.14.2.1
flutterflutter0.0.00.0.0
rxdart^0.26.00.26.00.27.2
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.2.0
collection-1.15.01.15.0
meta-1.7.01.7.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.26.0` on rxdart does not support the stable version `0.27.0`.

Try running dart pub upgrade --major-versions rxdart to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.3, Flutter 2.5.2, Dart 2.14.3.

9
likes
90
pub points
83%
popularity

A Calendar Custom Widget, you can selected dates, limited dates, and beautiful interface

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

animate_do, animated_text_kit, flutter, rxdart

More

Packages that depend on calendar_calendar