by_sliding_panel 1.0.0

  • Readme
  • Changelog
  • Example
  • Installing
  • new54

BySlidingPanel #

pub package author

A Sliding Panel Item Widget.

Feature #

  • 支持左右设置按钮;
  • 手势滑动速度和滑动距离过半判定

Get Started #

Add Dependency #

dependencies:
  by_sliding_panel: ^1.0.0

Usage #

import 'package:by_sliding_panel/by_sliding_panel.dart';

child: BySlidingPanel();

Support or Contact #

1.0.0 - 2020/07/01 #

example/lib/main.dart

import 'package:by_sliding_panel/by_sliding_panel.dart';
import 'package:flutter/material.dart';

import 'base/page_widget.dart';

void main() {
  runApp(MyApp());
}

class MyApp extends StatelessWidget {
  // This widget is the root of your application.
  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      title: 'Pandora Demo',
      theme: ThemeData(
        primarySwatch: Colors.lightGreen,
        visualDensity: VisualDensity.adaptivePlatformDensity,
      ),
      home: MyHomePage(title: 'BySlidingPanel Demo'),
    );
  }
}

class MyHomePage extends BasePageWidget {
  MyHomePage({Key key, this.title}) : super(key: key);

  final String title;

  @override
  _MyHomePageState createState() => _MyHomePageState();
}

class _MyHomePageState extends BasePageState<MyHomePage> {
  final double rightWidth = 72;
  final double leftWidth = 50;

  var _sliderState = SlideState.CLOSE;

  @override
  String getTitle() {
    return 'SlidingPanel Demo';
  }

  @override
  buildBody() => Container(
        padding: EdgeInsets.symmetric(vertical: 16.0, horizontal: 8.0),
        child: BySlidingPanel(
          state: _sliderState,
          child: Container(
            padding: EdgeInsets.all(16.0),
            child: Row(
              mainAxisAlignment: MainAxisAlignment.center,
              children: [Text('TRY TO SLIDE', style: TextStyle(color: Colors.white))],
            ),
            color: Colors.blue,
          ),
          leftButtonWidth: leftWidth,
          leftButtons: [
            GestureDetector(
              behavior: HitTestBehavior.opaque,
              child: Container(
                width: leftWidth,
                color: Colors.teal,
                child: Center(
                  child: Text('H', style: TextStyle(color: Colors.white)),
                ),
              ),
              onTap: () => toast('Head Button Clicked'),
            ),
            GestureDetector(
              behavior: HitTestBehavior.opaque,
              child: Container(
                width: leftWidth,
                color: Colors.green,
                child: Center(
                  child: Text('N', style: TextStyle(color: Colors.white)),
                ),
              ),
              onTap: () => toast('Neck Button Clicked'),
            ),
          ],
          rightButtonWidth: rightWidth,
          rightButtons: [
            GestureDetector(
              behavior: HitTestBehavior.opaque,
              child: Container(
                width: rightWidth,
                color: Colors.red,
                child: Center(
                  child: Text('BEHIND', style: TextStyle(color: Colors.white)),
                ),
              ),
              onTap: () => toast('Right Button Clicked'),
            ),
          ],
          onItemTap: () => toast('Content Clicked'),
        ),
      );
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  by_sliding_panel: ^1.0.0

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:by_sliding_panel/by_sliding_panel.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
8
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
54
Learn more about scoring.

We analyzed this package on Jul 3, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.13
  • Flutter: 1.17.5

Analysis suggestions

Package not compatible with SDK dart

because of import path [by_sliding_panel] that is in a package requiring null.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.7.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8
Dev dependencies
flutter_test