butterfly_host_sdk 0.1.1
butterfly_host_sdk: ^0.1.1 copied to clipboard

TheButterflyHost help you app to take part in the fight against domestic violent.

TheButterflyHost help you app to take part in the fight against domestic violent.

Installation #

🔌 & ▶️ #

Our plugin is pretty straight forward and easy to install, all you need to do is add butterfly_host_sdk dependency . To recognize your app in ButterflyHostSDK servers you need an application key, you can set it via code.

Required changes in your pubspec.yaml file:

dependencies:
  flutter:
    sdk: flutter
...
  butterfly_host_sdk: 0.1.1
...

Becuse the SDK uses Jitpack.io:

  • in your flutter_app/Android/app/build.gradle set your minSdkVersion 21
  • in your flutter_app/Android/build.gradle add :
buildscript {
    ext.kotlin_version = '1.4.31'
    repositories {
       ....
    }

    dependencies {
     ...
     classpath "org.jetbrains.kotlin:kotlin-gradle-plugin:$kotlin_version"
    }
}
allprojects {
    repositories {
        maven { url 'https://jitpack.io' } // first
        google()
        jcenter()
    }
}

Example #

import 'package:butterfly_sdk/butterfly_host_sdk.dart';
  
     ButterflyHostSDK.butterflyHost("YOU_API_KEY");

Comments #

  • This SDK using a method channel for better performances.
0
likes
80
pub points
0%
popularity

Publisher

Unknown

TheButterflyHost help you app to take part in the fight against domestic violent.

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter

More

Packages that depend on butterfly_host_sdk