built_union_generator 0.1.3
built_union_generator: ^0.1.3 copied to clipboard

Dart sum-types, compatible with built_value.dart This library is the dev dependency.

0
likes
60/ 130
pub points
3%
popularity

We analyzed this package on Oct 16, 2021, and awarded it 60 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

10/10 points: Provide a valid pubspec.yaml

0/5 points: Provide a valid README.md

No `README.md` found.

The README.md file should inform others about your project, what it does, and how they can use it. See: the example generated by stagehand.

0/5 points: Provide a valid CHANGELOG.md

No `CHANGELOG.md` found.

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

Provide documentation
0 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

0/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 6 API elements (16.7 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:built_union_generator/built_union_generator.dart that imports:
  • package:built_union_generator/src/builder.dart that imports:
  • package:built_union_generator/src/union_spec.dart that imports:
  • package:source_gen/source_gen.dart that imports:
  • package:source_gen/src/utils.dart that imports:
  • package:build/build.dart that imports:
  • package:build/src/generate/run_post_process_builder.dart that imports:
  • package:build/src/builder/post_process_builder.dart that imports:
  • package:build/src/builder/builder.dart that imports:
  • package:build/src/builder/build_step.dart that imports:
  • package:build/src/asset/reader.dart that imports:
  • package:glob/glob.dart that imports:
  • package:glob/src/list_tree.dart that imports:
  • package:glob/src/io.dart that imports:
  • package:glob/src/io_export.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer>=0.39.3 <0.40.00.39.172.6.0
build^1.1.01.6.22.1.1
built_collection>=2.0.0 <5.0.04.3.25.1.1
built_union^0.1.00.1.30.1.3
meta^1.1.01.7.01.7.0
source_gen^0.9.00.9.10+21.1.1
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-7.0.029.0.0
args-1.6.02.3.0
async-2.8.22.8.2
built_value-7.1.08.1.2
charcode-1.3.11.3.1
cli_util-0.2.00.3.5
clock-1.1.01.1.0
collection-1.15.01.15.0
convert-2.1.13.0.1
crypto-2.1.53.0.1
csslib-0.16.20.17.1
dart_style-1.3.62.2.0
file-5.2.16.1.2
fixnum-0.10.111.0.0
glob-1.2.02.0.2
html-0.14.0+40.15.0
intl-0.17.00.17.0
js-0.6.30.6.3
matcher-0.12.110.12.11
node_interop-1.2.12.1.0
node_io-1.2.02.1.0
package_config-1.9.32.0.2
path-1.8.01.8.0
pedantic-1.11.11.11.1
pub_semver-1.4.42.1.0
quiver-2.1.53.0.1+1
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
watcher-0.9.7+151.0.1
yaml-2.2.13.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 4 issues. Showing the first 2:

The constraint `>=0.39.3 <0.40.0` on analyzer does not support the stable version `0.40.0`.

Try running dart pub upgrade --major-versions analyzer to update the constraint.

The constraint `^1.1.0` on build does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions build to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.6.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.3, Dart 2.14.3.

0
likes
60
pub points
3%
popularity

Publisher

freedomlayer.org

Dart sum-types, compatible with built_value.dart This library is the dev dependency.

Repository (GitHub)
View/report issues

Documentation

API reference

Dependencies

analyzer, build, built_collection, built_union, meta, source_gen

More

Packages that depend on built_union_generator