build_node_compilers 0.3.1
build_node_compilers: ^0.3.1 copied to clipboard

Builders wrapping DDC and dart2js compilers configured to output Node modules.

7
likes
80 / 110
pub points
64 %
popularity

We analyzed this package on Apr 9, 2021, and awarded it 80 pub points (of a possible 110):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 11 out of 40 API elements (27.5 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 1 of 2 possible platforms (native, js)

Consider supporting multiple platforms:

Package not compatible with runtime js

Because:

  • package:build_node_compilers/build_node_compilers.dart that imports:
  • package:build_node_compilers/src/platforms.dart that imports:
  • package:build_modules/build_modules.dart that imports:
  • package:build_modules/src/workers.dart that imports:
  • package:build_modules/src/scratch_space.dart that imports:
  • package:scratch_space/scratch_space.dart that imports:
  • package:scratch_space/src/scratch_space.dart that imports:
  • package:build/build.dart that imports:
  • package:build/src/generate/run_post_process_builder.dart that imports:
  • package:build/src/builder/post_process_builder.dart that imports:
  • package:build/src/builder/builder.dart that imports:
  • package:build/src/builder/build_step.dart that imports:
  • package:build/src/asset/reader.dart that imports:
  • package:glob/glob.dart that imports:
  • package:glob/src/list_tree.dart that imports:
  • package:glob/src/io.dart that imports:
  • package:glob/src/io_export.dart that imports:
  • dart:io
Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
analyzer>=0.36.4 <0.41.00.39.171.4.0
bazel_worker^0.1.180.1.251.0.0
build>=1.3.0 <2.0.01.6.22.0.0
build_config>=0.3.0 <0.5.00.4.70.4.7
build_modules^2.11.32.11.33.0.6
collection^1.0.01.15.01.15.0
crypto^2.0.02.1.53.0.1
logging^0.11.30.11.41.0.1
meta^1.1.01.3.01.3.0
node_preamble^1.4.81.4.132.0.0
path^1.4.21.8.01.8.0
pool^1.3.61.5.01.5.0
scratch_space^0.0.20.0.4+31.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
_fe_analyzer_shared-7.0.020.0.0
args-1.6.02.0.0
async-2.5.02.5.0
charcode-1.2.01.2.0
checked_yaml-1.0.42.0.1
cli_util-0.2.00.3.0
clock-1.1.01.1.0
convert-2.1.13.0.0
csslib-0.16.20.17.0
file-5.2.16.1.0
fixnum-0.10.111.0.0
glob-1.2.02.0.1
graphs-0.2.02.0.0
html-0.14.0+40.15.0
intl-0.17.00.17.0
js-0.6.30.6.3
json_annotation-3.1.14.0.1
node_interop-1.2.11.2.1
node_io-1.2.01.2.0
package_config-1.9.32.0.0
protobuf-1.1.32.0.0
pub_semver-1.4.42.0.0
pubspec_parse-0.1.81.0.0
source_span-1.8.11.8.1
stack_trace-1.10.01.10.0
string_scanner-1.1.01.1.0
term_glyph-1.2.01.2.0
typed_data-1.3.01.3.0
watcher-0.9.7+151.0.0
yaml-2.2.13.1.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 8 issues. Showing the first 2:

The constraint `>=0.36.4 <0.41.0` on analyzer does not support the stable version `0.41.0`.

Try running dart pub upgrade --major-versions analyzer to update the constraint.

The constraint `^0.1.18` on bazel_worker does not support the stable version `1.0.0`.

Try running dart pub upgrade --major-versions bazel_worker to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Dart 2.12.2.