bubo 0.0.2
bubo: ^0.0.2 copied to clipboard

A combinatorial parser library writtren in Dart.

0
likes
80/ 130
pub points
0%
popularity

We analyzed this package on Oct 26, 2021, and awarded it 80 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/example.md

10/10 points: 20% or more of the public API has dartdoc comments

  • 40 out of 140 API elements (28.6 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 10 issues. Showing the first 2:

lib/combinators.dart doesn't match the Dart formatter.

To format your files run: dart format .

lib/core.dart doesn't match the Dart formatter.

To format your files run: dart format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
freezed_annotation^0.11.00.11.0+10.15.0
Transitive dependencies
PackageConstraintCompatibleLatest
collection-1.15.01.15.0
json_annotation-3.1.14.3.0
meta-1.7.01.7.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.11.0` on freezed_annotation does not support the stable version `0.12.0`.

Try running dart pub upgrade --major-versions freezed_annotation to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.7.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.3, Dart 2.14.3.

0
likes
80
pub points
0%
popularity

Publisher

ericd.dev

A combinatorial parser library writtren in Dart.

Homepage

Documentation

API reference

License

unknown (LICENSE)

Dependencies

freezed_annotation

More

Packages that depend on bubo