bubble_bottom_bar 2.0.0 copy "bubble_bottom_bar: ^2.0.0" to clipboard
bubble_bottom_bar: ^2.0.0 copied to clipboard

BubbleBottomBar is a Flutter widget designed by cubertodesign and developed by westdabestdb

220
likes
70/ 160
pub points
91%
popularity

We analyzed this package 9 hours ago, and awarded it 70 pub points (of a possible 160):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

partial
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

2 out of 28 API elements (7.1 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

To highlight public API members missing documentation consider enabling the public_member_api_docs lint.

Some symbols that are missing documentation: bubble_bottom_bar, bubble_bottom_bar.BubbleBottomBar, bubble_bottom_bar.BubbleBottomBar.BubbleBottomBar, bubble_bottom_bar.BubbleBottomBar.backgroundColor, bubble_bottom_bar.BubbleBottomBar.borderRadius.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
failed
Pass static analysis
0 / 50trigger folding of the section

0/50 points: code has no errors, warnings, lints, or formatting issues

Found 7 issues. Showing the first 2:

ERROR: The name 'Badge' is defined in the libraries 'package:badges/src/badge.dart (via package:badges/badges.dart)' and 'package:flutter/src/material/badge.dart (via package:flutter/material.dart)'.

lib/bubble_bottom_bar.dart:195:14

    ╷
195 │       child: Badge(
    │              ^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/bubble_bottom_bar.dart

ERROR: 'Badge' isn't a function.

lib/bubble_bottom_bar.dart:195:14

    ╷
195 │       child: Badge(
    │              ^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/bubble_bottom_bar.dart

failed
Support up-to-date dependencies
10 / 40trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
badges ^2.0.2 2.0.3 3.1.2
flutter flutter 0.0.0 0.0.0
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^2.0.2` on badges does not support the stable version `3.0.0`.

Try running dart pub upgrade --major-versions badges to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

0/20 points: Compatible with dependency constraint lower bounds

downgrade analysis failed failed with 2 errors:

  • AMBIGUOUS_IMPORT - lib/bubble_bottom_bar.dart:195:14 - The name 'Badge' is defined in the libraries 'package:badges/src/badge.dart (via package:badges/badges.dart)' and 'package:flutter/src/material/badge.dart (via package:flutter/material.dart)'.
  • INVOCATION_OF_NON_FUNCTION - lib/bubble_bottom_bar.dart:195:14 - 'Badge' isn't a function.

Run flutter pub downgrade and then flutter analyze to reproduce the above problem.

You may run dart pub upgrade --tighten to update your dependency constraints, see dart.dev/go/downgrade-testing for details.

Analyzed with Pana 0.22.9, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

220
likes
70
pub points
91%
popularity

Publisher

unverified uploader

BubbleBottomBar is a Flutter widget designed by cubertodesign and developed by westdabestdb

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (license)

Dependencies

badges, flutter

More

Packages that depend on bubble_bottom_bar