btc_address_validate 0.1.1
btc_address_validate: ^0.1.1 copied to clipboard

A minimal library to validate Bitcoin mainnet and testnet addresses

2
likes
90/ 130
pub points
61%
popularity

We analyzed this package 2 days ago, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 1 out of 26 API elements (3.8 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
30 / 30

30/30 points: code has no errors, warnings, lints, or formatting issues

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
base58check^1.0.11.0.12.0.0
bech32^0.1.20.1.20.2.1
equatable^1.1.11.2.62.0.3
Transitive dependencies
PackageConstraintCompatibleLatest
charcode-1.3.11.3.1
collection-1.15.01.15.0
convert-2.1.13.0.1
crypto-2.1.53.0.1
meta-1.7.01.7.0
typed_data-1.3.01.3.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 3 issues. Showing the first 2:

The constraint `^1.0.1` on base58check does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions base58check to update the constraint.

The constraint `^0.1.2` on bech32 does not support the stable version `0.2.0`.

Try running dart pub upgrade --major-versions bech32 to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.3.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.4, Dart 2.15.0.

2
likes
90
pub points
61%
popularity

A minimal library to validate Bitcoin mainnet and testnet addresses

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

base58check, bech32, equatable

More

Packages that depend on btc_address_validate