browser_launcher 1.0.0
browser_launcher: ^1.0.0 copied to clipboard

Provides a standardized way to launch web browsers for testing and tools.

1.0.0 #

  • Migrate to null-safety.

0.1.10 #

  • Support webkit_inspection_protocol version ^1.0.0.

0.1.9 #

  • Add support for Chrome executables in CHROME_PATH.

0.1.8 #

  • Log STDERR on Chrome launch failure.

0.1.7 #

  • Widen the dependency range on package:webkit_inspection_protocol.

0.1.6 #

  • Update lower Dart SDK requirement to 2.2.0.
  • Update the dependency range on package:webkit_inspection_protocol.

0.1.5 #

  • Add a parameter to use a specified user-data-dir instead of a system temp.

0.1.4 #

  • Start Chrome maximized.

0.1.3 #

  • widen the version constraint on package:webkit_inspection_protocol

0.1.2 #

  • lower min sdk version to match Flutter stable

0.1.1 #

  • added example

0.1.0 #

  • initial release
4
likes
120
pub points
95%
popularity

Publisher

tools.dart.dev

Provides a standardized way to launch web browsers for testing and tools.

Repository (GitHub)
View/report issues

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

path, webkit_inspection_protocol

More

Packages that depend on browser_launcher