brick_sqlite 1.0.0
brick_sqlite: ^1.0.0 copied to clipboard

SQLite connector for Brick, a data persistence library for Flutter

2
likes
110/ 130
pub points
59%
popularity

We analyzed this package 2 days ago, and awarded it 110 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/example.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 40 out of 51 API elements (78.4 %) have documentation comments.
Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 5 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Web`.

Because:

  • package:brick_sqlite/memory_cache_provider.dart that imports:
  • package:brick_sqlite/sqlite.dart that imports:
  • package:brick_sqlite/src/sqlite_provider.dart that imports:
  • package:brick_sqlite/src/sqlite_model_dictionary.dart that imports:
  • package:brick_sqlite/src/sqlite_adapter.dart that imports:
  • package:sqflite/sqflite.dart that declares support for platforms: Android, iOS, macOS.
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 6 issues. Showing the first 2:

lib/memory_cache_provider.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/src/helpers/alter_column_helper.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
20 / 20

10/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
brick_core^1.0.0+11.0.0+11.0.0+1
brick_sqlite_abstract^1.0.0+11.0.0+31.0.0+3
logging^1.0.01.0.21.0.2
meta^1.3.01.7.01.7.0
sqflite^2.0.0+12.0.0+42.0.0+4
synchronized^3.0.03.0.03.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.2.0
collection-1.15.01.15.0
path-1.8.01.8.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.4, Dart 2.14.4.