boustro 0.2.0 copy "boustro: ^0.2.0" to clipboard
boustro: ^0.2.0 copied to clipboard

A rich text editor for Flutter.

5
likes
80/ 140
pub points
1%
popularity

We analyzed this package 2 days ago, and awarded it 80 pub points (of a possible 140):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

OK
Provide documentation
20 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

747 out of 751 API elements (99.5 %) have documentation comments.

Some symbols that are missing documentation: boustro, convert_delta, convert_json, document.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
failed
Pass static analysis
0 / 50trigger folding of the section

0/50 points: code has no errors, warnings, lints, or formatting issues

Found 21 issues. Showing the first 2:

ERROR: The method 'FocusTrapArea' isn't defined for the type 'BoustroScaffold'.

lib/src/widgets/boustro_scaffold.dart:27:12

   ╷
27 │     return FocusTrapArea(
   │            ^^^^^^^^^^^^^
   ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/widgets/boustro_scaffold.dart

WARNING: This function has a nullable return type of 'Range?', but ends without returning a value.

lib/src/spans/attribute_span.dart:352:10

    ╷
352 │   Range? splice(Range removedSegment) {
    │          ^^^^^^
    ╵

To reproduce make sure you are using the lints_core and run flutter analyze lib/src/spans/attribute_span.dart

OK
Support up-to-date dependencies
20 / 20trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
built_collection ^5.0.0 5.1.1 5.1.1
characters ^1.1.0 1.3.0 1.3.0
collection ^1.15.0 1.18.0 1.18.0
equatable ^2.0.0 2.0.5 2.0.5
flutter flutter 0.0.0 0.0.0
meta ^1.2.4 1.11.0 1.12.0
Transitive dependencies
Package Constraint Compatible Latest
material_color_utilities - 0.8.0 0.8.0
sky_engine - 0.0.99 0.0.99
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.1, Dart 3.3.0.

Check the analysis log for details.