bottom_personalized_dot_bar 1.0.2
bottom_personalized_dot_bar: ^1.0.2 copied to clipboard

Bottom Personalized Dot Bar, Drag and drop all your items, customize your bottom navigation in the best way.

87
likes
90/ 130
pub points
73%
popularity

We analyzed this package on Sep 23, 2021, and awarded it 90 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
20 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

10/10 points: 20% or more of the public API has dartdoc comments

  • 37 out of 38 API elements (97.4 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 3 of 3 possible platforms (iOS, Android, Web)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

lib/bottom_personalized_dot_bar.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
dotted_border^1.0.21.0.72.0.0+1
flutterflutter0.0.00.0.0
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.2.0
collection-1.15.01.15.0
meta-1.7.01.7.0
path_drawing-0.4.1+10.5.1
path_parsing-0.1.40.2.1
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^1.0.2` on dotted_border does not support the stable version `2.0.0`.

Try running dart pub upgrade --major-versions dotted_border to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.1.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.21.1+1, Flutter 2.5.0, Dart 2.14.0.

87
likes
90
pub points
73%
popularity

Bottom Personalized Dot Bar, Drag and drop all your items, customize your bottom navigation in the best way.

Repository (GitHub)
View/report issues

Documentation

API reference

License

unknown (LICENSE)

Dependencies

dotted_border, flutter

More

Packages that depend on bottom_personalized_dot_bar