bootstrap_flutter 1.0.0 copy "bootstrap_flutter: ^1.0.0" to clipboard
bootstrap_flutter: ^1.0.0 copied to clipboard

Aplicação de responsividade do bootstrap para facilitar a criação de multiplos tamanhos de telas em seus projetos

30
likes
120/ 140
pub points
52%
popularity

We analyzed this package 6 days ago, and awarded it 120 pub points (of a possible 140):

OK
Follow Dart file conventions
30 / 30trigger folding of the section

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: MIT.

partial
Provide documentation
10 / 20trigger folding of the section

0/10 points: 20% or more of the public API has dartdoc comments

4 out of 40 API elements (10.0 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Some symbols that are missing documentation: bootstrap_flutter, bootstrap_flutter.BoxConstraintsExt, bootstrap_flutter.BoxConstraintsExt.getScreenType, bootstrap_flutter.Component, bootstrap_flutter.Component.Component.

10/10 points: Package has an example

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 6 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS
  • ✓ Web
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

failed
Support up-to-date dependencies
10 / 20trigger folding of the section

0/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
golden_toolkit ^0.11.0 0.11.0 0.15.0
Transitive dependencies
Package Constraint Compatible Latest
async - 2.11.0 2.11.0
boolean_selector - 2.1.1 2.1.1
characters - 1.3.0 1.3.0
clock - 1.1.1 1.1.1
collection - 1.18.0 1.18.0
fake_async - 1.3.1 1.3.1
flutter_test - 0.0.0 0.0.0
leak_tracker - 10.0.0 10.0.4
leak_tracker_flutter_testing - 2.0.1 3.0.3
leak_tracker_testing - 2.0.1 3.0.1
matcher - 0.12.16+1 0.12.16+1
material_color_utilities - 0.8.0 0.8.0
meta - 1.11.0 1.12.0
path - 1.9.0 1.9.0
sky_engine - 0.0.99 0.0.99
source_span - 1.10.0 1.10.0
stack_trace - 1.11.1 1.11.1
stream_channel - 2.1.2 2.1.2
string_scanner - 1.2.0 1.2.0
term_glyph - 1.2.1 1.2.1
test_api - 0.6.1 0.7.0
vector_math - 2.1.4 2.1.4
vm_service - 13.0.0 14.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.11.0` on golden_toolkit does not support the stable version `0.12.0`.

Try running dart pub upgrade --major-versions golden_toolkit to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analyzed with Pana 0.22.2, Flutter 3.19.1, Dart 3.3.0.

Check the analysis log for details.

30
likes
120
pub points
52%
popularity

Publisher

verified publishergabul.dev

Aplicação de responsividade do bootstrap para facilitar a criação de multiplos tamanhos de telas em seus projetos

Homepage
Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, golden_toolkit

More

Packages that depend on bootstrap_flutter