bootstrap_bundle 1.1.0

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 67

Bootstrap Bundle for Dart #

Dart Bootstrap jQuery Release License

Bundle providing Bootstrap and jQuery in one Dart package.

A front-end framework for developing responsive, mobile first projects on the Web.

Documentation #

Development #

License #

Bootstrap Bundle for Dart is distributed under the MIT License.

Changelog #

Version 1.1.0

Version 1.0.0

  • First stable release.
  • Provides jQuery 3.4.0.

Version 0.2.1

Version 0.2.0

Version 0.1.0 #

example/main.dart

import 'package:bootstrap_bundle/bootstrap_bundle.dart';

/// Prints the version numbers of the available libraries.
void main() {
  print('Bootstrap: $bootstrapVersion');
  print('jQuery: $jQueryVersion');
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  bootstrap_bundle: ^1.1.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:bootstrap_bundle/bootstrap_bundle.dart';
  
Version Uploaded Documentation Archive
1.1.0 May 10, 2019 Go to the documentation of bootstrap_bundle 1.1.0 Download bootstrap_bundle 1.1.0 archive
1.0.0 Apr 12, 2019 Go to the documentation of bootstrap_bundle 1.0.0 Download bootstrap_bundle 1.0.0 archive
0.2.1 Feb 18, 2019 Go to the documentation of bootstrap_bundle 0.2.1 Download bootstrap_bundle 0.2.1 archive
0.2.0 Feb 11, 2019 Go to the documentation of bootstrap_bundle 0.2.0 Download bootstrap_bundle 0.2.0 archive
0.1.0 Jan 19, 2019 Go to the documentation of bootstrap_bundle 0.1.0 Download bootstrap_bundle 0.1.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
34
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
67
Learn more about scoring.

We analyzed this package on Jun 4, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.3.1
  • pana: 0.12.17

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in primary library package:bootstrap_bundle/bootstrap_bundle.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.3.0 <3.0.0
Dev dependencies
grinder ^0.8.3