bootstrap 4.0.0

  • Readme
  • Changelog
  • Installing
  • 18

Bootstrap for Pub #

Build Status

Just a pub package of Bootstrap, "The most popular front-end framework for developing responsive, mobile first projects on the web."

Currently contains Bootstrap 4.0.0

Installation #

See the install instructions.

Usage #

You can include the bootstrap stylesheets and script once you have added this package as a dependency to your application:

    <!-- include the stylesheets -->
    <link rel="stylesheet" href="packages/bootstrap/css/bootstrap.min.css">
    
    <!-- include the javascript -->
    <script src="https://code.jquery.com/jquery-3.2.1.slim.min.js" integrity="sha384-KJ3o2DKtIkvYIK3UENzmM7KCkRr/rE9/Qpg6aAZGJwFDMVNA/GpGFF93hXpG5KkN" crossorigin="anonymous"></script>
    <script src="https://cdnjs.cloudflare.com/ajax/libs/popper.js/1.12.9/umd/popper.min.js" integrity="sha384-ApNbgh9B+Y1QKtv3Rn7W3mgPxhU9K/ScQsAP7hUibX39j7fakFPskvXusvfa0b4Q" crossorigin="anonymous"></script>

Note that the versions in the snippets above are the non-minified version. The transformer available in this package will automatically rewrite the URI to point to the minified versions when pub is invoked in release mode.

To activate the transformer, update your pubspec.yaml

transformers:
- bootstrap:
    url: //maxcdn.bootstrapcdn.com/bootstrap/{{version}}
    version: 4.0.0

The transformer takes up to two optional parameters:

  • url: when specified the local base url (packages/bootstrap/) will be replaced by the given url. This is useful to automatically switch to using a CDN for your production environment.
  • version: when specified, the sub-string "{{version}}" in the url parameter will be replaced with its value.

Learn more #

Visit the official Bootstrap homepage for docs and more.

See LICENSE.

CHANGELOG #

4.0.0 #

  • Update package to bootstrap 4.0.0

4.0.0-beta.3 #

  • Update package to bootstrap 4.0.0-beta.3

4.0.0-alpha.6 #

  • Update package to bootstrap 4.0.0-alpha.6

3.3.0+7 #

  • Update package to bootstrap 3.3.7 and jquery 3.1.1

3.3.0+6 #

  • Update package to bootstrap 3.3.6 and jquery 2.2.4

3.3.0+4 #

  • Change name from bootstrap_for_pub to bootstrap

3.3.0+2 #

  • Bump versions of dependencies

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  bootstrap: ^4.0.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:bootstrap/bootstrap.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
35
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
18
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://dart.dev/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.