bonsoir_linux_dbus 0.1.3
bonsoir_linux_dbus: ^0.1.3 copied to clipboard

Linux platform interface for bonsoir package.

2
likes
70/ 130
pub points
33%
popularity

We analyzed this package on Nov 30, 2021, and awarded it 70 pub points (of a possible 130):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 3 out of 6 API elements (50.0 %) have documentation comments.
Support multiple platforms
0 / 20

0/20 points: Supports 0 of 3 possible platforms (iOS, Android, Web)

Found 7 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform `Android`.

Because:

  • package:bonsoir_linux_dbus/bonsoir_linux_dbus.dart that declares support for platforms: Linux.
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 3 issues. Showing the first 2:

lib/src/avahi_defs/service_browser.dart doesn't match the Dart formatter.

To format your files run: flutter format .

lib/src/linux_dbus_bonsoir_broadcast.dart doesn't match the Dart formatter.

To format your files run: flutter format .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
bonsoir_platform_interface^1.1.01.1.0+11.1.0+1
dbus^0.3.30.3.30.6.6
flutterflutter0.0.00.0.0
meta^1.3.01.7.01.7.0
Transitive dependencies
PackageConstraintCompatibleLatest
args-2.3.02.3.0
characters-1.1.01.2.0
collection-1.15.01.15.0
pedantic-1.11.11.11.1
petitparser-4.4.04.4.0
plugin_platform_interface-2.0.22.0.2
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.1
xml-5.3.15.3.1

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.3.3` on dbus does not support the stable version `0.4.0`.

Try running dart pub upgrade --major-versions dbus to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
20 / 20

20/20 points: Package and dependencies are fully migrated to null safety!

Analysed with Pana 0.21.4, Flutter 2.5.3, Dart 2.14.4.