bmap_map_fluttify 0.1.4+3
bmap_map_fluttify: ^0.1.4+3 copied to clipboard

An `BaiduMap` Map Component, Powered By `Fluttify` Engine, Which Generates Dart Binding For Native SDK.

1
likes
65 / 130
pub points
49 %
popularity

We analyzed this package on Jul 28, 2021, and awarded it 65 pub points (of a possible 130):

Follow Dart file conventions
15 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

0/5 points: Provide a valid CHANGELOG.md

`CHANGELOG.md` contains too many non-ASCII characters.

The site uses English as its primary language. The content of CHANGELOG.md in your package should primarily contain characters used in English.

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 162 out of 9244 API elements (1.8 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 9 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:bmap_map_fluttify/bmap_map_fluttify.dart that declares support for platforms: Android, iOS
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 392 issues. Showing the first 2:

lib/src/android/com/baidu/geofence/GeoFence.g.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/src/android/com/baidu/geofence/GeoFenceClient.g.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
bmap_core_fluttify^0.2.30.2.30.3.1
bmap_utils_fluttify^0.1.00.1.00.2.1
core_location_fluttify^0.2.40.2.40.6.0
flutterflutter0.0.00.0.0
foundation_fluttify^0.8.100.8.120.11.1
path_provider^1.6.111.6.282.0.2
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
collection-1.15.01.15.0
ffi-1.1.21.1.2
file-6.1.26.1.2
latlng-0.1.00.1.0
meta-1.3.01.7.0
path-1.8.01.8.0
path_provider_linux-0.0.1+22.0.2
path_provider_macos-0.0.4+82.0.2
path_provider_platform_interface-1.0.42.0.1
path_provider_windows-0.0.52.0.3
platform-3.0.03.0.0
plugin_platform_interface-1.0.32.0.1
process-4.2.34.2.3
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0
win32-2.2.52.2.5
xdg_directories-0.1.20.2.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

Found 5 issues. Showing the first 2:

The constraint `^0.2.3` on bmap_core_fluttify does not support the stable version `0.3.0`.

Try running dart pub upgrade --major-versions bmap_core_fluttify to update the constraint.

The constraint `^0.1.0` on bmap_utils_fluttify does not support the stable version `0.2.0`.

Try running dart pub upgrade --major-versions bmap_utils_fluttify to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.6.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.19.0, Flutter 2.2.3, Dart 2.13.4.

1
likes
65
pub points
49%
popularity

Publisher

fluttify.com

An `BaiduMap` Map Component, Powered By `Fluttify` Engine, Which Generates Dart Binding For Native SDK.

Homepage

Documentation

API reference

License

GPL 3.0 (LICENSE)

Dependencies

bmap_core_fluttify, bmap_utils_fluttify, core_location_fluttify, flutter, foundation_fluttify, path_provider

More

Packages that depend on bmap_map_fluttify