bmap_core_fluttify 0.3.1
bmap_core_fluttify: ^0.3.1 copied to clipboard

An `BaiduMap` Core Component, Powered By `Fluttify` Engine, Which Generates Dart Binding For Native SDK.

0
likes
70 / 130
pub points
41 %
popularity

We analyzed this package on Aug 3, 2021, and awarded it 70 pub points (of a possible 130):

Follow Dart file conventions
20 / 20

10/10 points: Provide a valid pubspec.yaml

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

10/10 points: Package has an example

  • Found example at: example/lib/main.dart

0/10 points: 20% or more of the public API has dartdoc comments

  • 10 out of 350 API elements (2.9 %) have documentation comments.

Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API. Document at least 20% of the public API elements.

Support multiple platforms
10 / 20

10/20 points: Supports 2 of 3 possible platforms (iOS, Android, Web)

Found 6 issues. Showing the first 2:

Consider supporting multiple platforms:

Package does not support Flutter platform Web

Because:

  • package:bmap_core_fluttify/bmap_core_fluttify.dart that declares support for platforms: Android, iOS
Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 25 issues. Showing the first 2:

lib/src/android/constants.g.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

lib/src/android/type_op.g.dart is not formatted according to dartfmt

To format your files run: dartfmt -w .

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
core_location_fluttify^0.4.10.4.10.6.0
flutterflutter0.0.00.0.0
foundation_fluttify^0.9.50.9.10+10.11.1
Transitive dependencies
PackageConstraintCompatibleLatest
characters-1.1.01.1.0
collection-1.15.01.15.0
meta-1.3.01.7.0
sky_engine-0.0.990.0.99
typed_data-1.3.01.3.0
vector_math-2.1.02.1.0

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.4.1` on core_location_fluttify does not support the stable version `0.5.0`.

Try running dart pub upgrade --major-versions core_location_fluttify to update the constraint.

The constraint `^0.9.5` on foundation_fluttify does not support the stable version `0.10.0`.

Try running dart pub upgrade --major-versions foundation_fluttify to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Support sound null safety
0 / 20

0/20 points: Package does not opt in to null safety.

Package language version (indicated by the sdk constraint `>=2.6.0 <3.0.0`) is less than 2.12.

Consider migrating.

Analysed with Pana 0.19.0, Flutter 2.2.3, Dart 2.13.4.

0
likes
70
pub points
41%
popularity

Publisher

fluttify.com

An `BaiduMap` Core Component, Powered By `Fluttify` Engine, Which Generates Dart Binding For Native SDK.

Homepage

Documentation

API reference

License

Apache 2.0 (LICENSE)

Dependencies

core_location_fluttify, flutter, foundation_fluttify

More

Packages that depend on bmap_core_fluttify