bluetooth_enable 0.0.3

  • Readme
  • Changelog
  • Example
  • Installing
  • 66

Introduction #

BluetoothEnable is a bluetooth plugin for Flutter, to programtically request turning on Bluetooth within applications.

This plugin is for Android only.

Usage #

// Request to turn on Bluetooth within an app
BluetoothEnable.enableBluetooth.then((value){
  //Do something with value
  //On success, returns "true". On error, returns "false"
    print(value);
  });  

0.0.3 #

  • Fix missing API call

0.0.2 #

  • Fix returning value on action

0.0.1 #

  • New release

example/lib/main.dart

import 'package:flutter/material.dart';
import 'package:bluetooth_enable/bluetooth_enable.dart';

void main() => runApp(MyApp());

class MyApp extends StatefulWidget {
  @override
  _MyAppState createState() => _MyAppState();
}

class _MyAppState extends State<MyApp> {

  @override
  void initState() {
    super.initState();
  }

  Future<void> test() async{
    BluetoothEnable.enableBluetooth.then((value){
      print(value);
    });    
  }

  @override
  Widget build(BuildContext context) {
    return MaterialApp(
      home: Scaffold(
        appBar: AppBar(
          title: const Text(
            'Turn on Bluetooth',
          ),
          centerTitle: true,
        ),
        body: Center(
          child: Column(
            mainAxisSize: MainAxisSize.min,
            mainAxisAlignment: MainAxisAlignment.center,
            children: <Widget>[
              Text("Press the button to request turning on Bluetooth"),
              SizedBox(height: 20.0),
              RaisedButton(
                onPressed: (() {
                  test();
                }),
                child: Text('Request to turn on Bluetooth'),
              ),
            ],
          ),
        ),
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  bluetooth_enable: ^0.0.3

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter pub get

Alternatively, your editor might support flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:bluetooth_enable/bluetooth_enable.dart';
  
Popularity:
Describes how popular the package is relative to other packages. [more]
37
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
66
Learn more about scoring.

We analyzed this package on Jul 9, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.14
  • Flutter: 1.17.5

Analysis suggestions

Package does not support Flutter platform linux

Because:

  • package:bluetooth_enable/bluetooth_enable.dart that declares support for platforms: android, ios

Package does not support Flutter platform macos

Because:

  • package:bluetooth_enable/bluetooth_enable.dart that declares support for platforms: android, ios

Package does not support Flutter platform web

Because:

  • package:bluetooth_enable/bluetooth_enable.dart that declares support for platforms: android, ios

Package does not support Flutter platform windows

Because:

  • package:bluetooth_enable/bluetooth_enable.dart that declares support for platforms: android, ios

Package not compatible with SDK dart

Because:

  • bluetooth_enable that is a package requiring null.

Health issues and suggestions

Document public APIs. (-1 points)

5 out of 5 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Format lib/bluetooth_enable.dart.

Run flutter format to format lib/bluetooth_enable.dart.

Maintenance suggestions

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8 1.2.1
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8 2.1.0-nullsafety
Dev dependencies
flutter_test