bluejay 1.4.0
bluejay: ^1.4.0 copied to clipboard

A curated collection of useful Flutter and Dart widgets, classes, and extensions

example/lib/main.dart

import 'package:bluejay/bluejay.dart';
import 'package:flutter/material.dart';
import 'package:provider/provider.dart';

import 'bluejay_colors.dart';
import 'bluejay_gallery.dart';

void main() {
  WidgetsFlutterBinding.ensureInitialized();
  printFullStacktraces();
  runApp(
    MyApp(),
  );
}

class MyApp extends StatelessWidget {
  @override
  Widget build(BuildContext context) {
    return Provider(
      create: (context) => LoggingService(
        loggers: {
          ConsoleLogger(),
        },
      ),
      child: MaterialApp(
        title: 'Bluejay Gallery',
        theme: ThemeData(
          //brightness: Brightness.light,
          primarySwatch: bluejayPrimary,
          visualDensity: VisualDensity.adaptivePlatformDensity,
        ),
        home: BluejayGallery(),
      ),
    );
  }
}
0
likes
130
pub points
53%
popularity

Publisher

groovinchip.dev

A curated collection of useful Flutter and Dart widgets, classes, and extensions

Repository (GitHub)
View/report issues

Documentation

API reference

License

MIT (LICENSE)

Dependencies

flutter, http

More

Packages that depend on bluejay