bloc_flutter 0.1.0

  • Readme
  • Changelog
  • Installing
  • 35

bloc_flutter #

flutter bloc

Getting Started #

This project is a starting point for a Dart package, a library module containing code that can be shared easily across multiple Flutter or Dart projects.

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

[ 0.1.0] - 2019-05-03 #

Initial release

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  bloc_flutter: ^0.1.0

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter pub get

Alternatively, your editor might support pub get or flutter pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:bloc_flutter/bloc_flutter.dart';
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Jul 2, 2020, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.8.4
  • pana: 0.13.9+1
  • Flutter: 1.17.3

Health issues and suggestions

Fix lib/src/state_builder.dart. (-68.36 points)

Analysis of lib/src/state_builder.dart failed with 4 errors:

line 4 col 45: Undefined class 'BlocState'.

line 13 col 31: Undefined class 'BlocEvent'.

line 13 col 53: Undefined class 'BlocState'.

line 15 col 9: Undefined class 'EventStateBaseBloc'.

Fix lib/src/bloc_provider.dart. (-58.02 points)

Analysis of lib/src/bloc_provider.dart failed with 3 errors, 1 hint:

line 143 col 30: Undefined class 'BaseBloc'.

line 156 col 25: Undefined class 'BaseBloc'.

line 164 col 36: Undefined class 'BaseBloc'.

line 159 col 17: 'ancestorInheritedElementForWidgetOfExactType' is deprecated and shouldn't be used. Use getElementForInheritedWidgetOfExactType instead. This feature was deprecated after v1.12.1..

Format lib/bloc_flutter.dart.

Run flutter format to format lib/bloc_flutter.dart.

Maintenance issues and suggestions

No valid SDK. (-20 points)

The analysis could not detect a valid SDK that can use this package.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is getting outdated. (-16.71 points)

The package was last published 60 weeks ago.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and bloc_flutter.dart. Packages with multiple examples should provide example/

For more information see the pub package layout conventions.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
bloc_base ^0.1.0 0.1.0
flutter 0.0.0
Transitive dependencies
collection 1.14.12 1.14.13
meta 1.1.8 1.2.0
rxdart 0.21.0 0.24.1
sky_engine 0.0.99
typed_data 1.1.6 1.2.0
vector_math 2.0.8
Dev dependencies