bloc_annotation 0.0.2
bloc_annotation: ^0.0.2 copied to clipboard

Generates the BLoC Boilerplate.

0
likes
70 / 110
pub points
5 %
popularity

We analyzed this package on Apr 21, 2021, and awarded it 70 pub points (of a possible 110):

Follow Dart file conventions
10 / 20

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

Provide documentation
10 / 20

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

10/10 points: 20% or more of the public API has dartdoc comments

  • 16 out of 24 API elements (66.7 %) have documentation comments.
Support multiple platforms
20 / 20

20/20 points: Supports 2 of 2 possible platforms (native, js)

Pass static analysis
20 / 30

20/30 points: code has no errors, warnings, lints, or formatting issues

Found 7 issues. Showing the first 2:

INFO: Unused import: 'package:rxdart/rxdart.dart'.

lib/src/bloc.dart:3:8

  ╷
3 │ import 'package:rxdart/rxdart.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/bloc.dart

INFO: Unused import: 'package:meta/meta.dart'.

lib/src/bloc.dart:5:8

  ╷
5 │ import 'package:meta/meta.dart';
  │        ^^^^^^^^^^^^^^^^^^^^^^^^
  ╵

To reproduce make sure you are using pedantic and run dartanalyzer lib/src/bloc.dart

Support up-to-date dependencies
10 / 20

0/10 points: All of the package dependencies are supported in the latest version

PackageConstraintCompatibleLatest
meta^1.1.61.3.01.3.0
rxdart^0.20.00.20.00.26.0

To reproduce run pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

The constraint `^0.20.0` on rxdart does not support the stable version `0.21.0`.

Try running dart pub upgrade --major-versions rxdart to update the constraint.

10/10 points: Package supports latest stable Dart and Flutter SDKs

Analysed with Pana 0.15.4, Dart 2.12.2.