blip_sdk 0.0.26 copy "blip_sdk: ^0.0.26" to clipboard
blip_sdk: ^0.0.26 copied to clipboard

A simple SDK built for BLiP using Flutter/Dart

2
likes
140/ 160
pub points
37%
popularity

We analyzed this package 35 hours ago, and awarded it 140 pub points (of a possible 160):

failed
Follow Dart file conventions
20 / 30trigger folding of the section

0/10 points: Provide a valid pubspec.yaml

The package description is too short.

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

5/5 points: Provide a valid README.md

5/5 points: Provide a valid CHANGELOG.md

10/10 points: Use an OSI-approved license

Detected license: BSD-3-Clause.

failed
Provide documentation
10 / 20trigger folding of the section

10/10 points: 20% or more of the public API has dartdoc comments

262 out of 422 API elements (62.1 %) have documentation comments.

Some symbols that are missing documentation: blip_sdk, blip_sdk.Application.authentication, blip_sdk.Application.commandTimeout, blip_sdk.Application.compression, blip_sdk.Application.domain.

0/10 points: Package has an example

No example found.

See package layout guidelines on how to add an example.

OK
Platform support
20 / 20trigger folding of the section

20/20 points: Supports 5 of 6 possible platforms (iOS, Android, Web, Windows, macOS, Linux)

  • ✓ Android
  • ✓ iOS
  • ✓ Windows
  • ✓ Linux
  • ✓ macOS

These platforms are not supported:

Package not compatible with platform Web

Because:

  • package:blip_sdk/blip_sdk.dart that imports:
  • package:blip_sdk/src/extensions/media/media.extension.dart that imports:
  • package:blip_sdk/src/extensions/base.extension.dart that imports:
  • package:blip_sdk/src/client.dart that imports:
  • package:blip_sdk/src/models/listener_model.dart that imports:
  • package:lime/lime.dart that imports:
  • package:lime/src/protocol/network/web_socket_transport.dart that imports:
  • package:lime/src/protocol/network/transport.dart that imports:
  • dart:io
OK
Pass static analysis
50 / 50trigger folding of the section

50/50 points: code has no errors, warnings, lints, or formatting issues

OK
Support up-to-date dependencies
40 / 40trigger folding of the section

10/10 points: All of the package dependencies are supported in the latest version

Package Constraint Compatible Latest
flutter flutter 0.0.0 0.0.0
lime ^0.0.25 0.0.25 0.0.25
Transitive dependencies
Package Constraint Compatible Latest
characters - 1.3.0 1.3.0
collection - 1.18.0 1.19.0
crypto - 3.0.3 3.0.3
logging - 1.2.0 1.2.0
material_color_utilities - 0.8.0 0.12.0
meta - 1.12.0 1.15.0
path - 1.9.0 1.9.0
pretty_json - 2.0.0 2.0.0
simple_logger - 1.9.0+3 1.9.0+3
sky_engine - 0.0.99 0.0.99
stack_trace - 1.11.1 1.11.1
typed_data - 1.3.2 1.3.2
uuid - 3.0.7 4.4.0
vector_math - 2.1.4 2.1.4

To reproduce run dart pub outdated --no-dev-dependencies --up-to-date --no-dependency-overrides.

10/10 points: Package supports latest stable Dart and Flutter SDKs

20/20 points: Compatible with dependency constraint lower bounds

pub downgrade does not expose any static analysis error.

Analyzed with Pana 0.22.7, Flutter 3.22.2, Dart 3.4.3.

Check the analysis log for details.

2
likes
140
pub points
37%
popularity

Publisher

verified publisherblip.ai

A simple SDK built for BLiP using Flutter/Dart

Homepage
Repository (GitHub)
View/report issues
Contributing

Documentation

API reference

License

BSD-3-Clause (LICENSE)

Dependencies

flutter, lime

More

Packages that depend on blip_sdk